Cannot connect to server on mobile app only when on wifi

I cannot connect to a Mattermost server using the mobile app from my wifi network. I can connect on mobile networks, from my mobile browser (even on wifi), etc.

Steps to reproduce
Connect to my home wifi, open Mattermost mobile app, attempt to connect to a server

Expected behavior
I should reach the login screen after entering the server URL

Observed behavior
Receive the message “Cannot connect to server”

Hi @CorpulentBrony and welcome to the Mattermost forums!

I can see that your server has IPv6 addresses and there are sometimes issues with half-working IPv6 implementations in networks, so can you verify that IPv6 is working just fine in your home network? You can f.ex. visit sites like on your mobile to verify that you’re connected with an IPv6 address. If it only shows an IPv4 address for you, then it’s very likely that IPv6 has issues in your local WIFI and this is probably also the reason why you cannot connect to the server then. To verify my assumption you could also try to disable IPv6 on your mobile device temporarily.

Thanks for the reply!
That site only shows an IPv4 address.
And I’m not aware of a way to disable IPv6 on wifi on Android, so unsure if that’s an option.

OK, then this might be the problem. Not sure how to further debug that on your device and I’m not using an Android here either so I can’t give you exact instructions. Can you try to find out if your WiFi assigned an IPv6 address to you?

And maybe you can also find a way there to disable the IPv6 address or not use DHCP but only use a static IPv4 address for testing purposes. If you have access to your WiFi router you might also want to check there for problems. Do you have other devices connected to this WiFi, something where it’s easier to run debugging commands like a PC?

Looks like maybe this is something Mattermost devs can address on their side.
Reddit appears to have run into and solved a similar issue on their app
What’s the best way to make them aware?

Yes, it is - it’s called happy eyeballs support and has already been requested, but this doesn’t help you to get a working connection in your WiFi in the short run, because development has not yet been started on this feature to better handle such connection situations. So for the time being you could either wait for them to fix it (which might take some time) or try to fix your WiFi.

Hopefully they’ll address it soon.
In the meantime until the Mattermost devs can correct the issue on their side, I can resort to using a VPN when on this or any other wifi network that has this issue.
This is the only app giving me any issue.


Actually it would be interesting to see what your Wifi’s problem is. Can you connect to IPv6 sites using a PC connected to your Wifi?

Got a quick and easy way to test that?

I haven’t refreshed my ISP connection in a few months, I wonder if something got funky with the IPv6 address range assigned to me by the ISP. Thinking this may correct the problem, but if you’re curious and want me to connect some information before I do that, let me know.

If you have a Windows PC connected to your Wifi, please share the output of ipconfig /all as well as route print. Then try to ping your Mattermost server and see if it returns an IPv4 or an IPv6 address in the command window and also try to ping and share the output.

If you’re on Linux, the commands are ip aas well as ip route show && ip -6 route show. Linux also has a separate ping6 utility for pinging IPv6 addresses.

For OSX I think it’s ifconfig -a and netstat -rn as well as maybe netstat -6rn, but I’m unsure on that and can’t test it at the moment.