Colored emojis between different browsers


Maybe someone can help me with an emoji problem or a unicode problem. Everything’s fine in the message window but the channel window causes some headache.

First I have to say I’m using Arch Linux on my private desktop. My wife uses Ubuntu 18.04 on her private laptop, as do I on my work laptop. We often recommend using Rambox for messaging needs; basically it’s a website wrapper for several messaging and mailing services built upon Chromium. When using unicode characters like emojis in the channel names they are black & white in Rambox, Vivaldi, and Chromium, but colored in Firefox. But only on my desktop and my wife’s laptop. On my work laptop they are colored also in Rambox. Eventually, Firefox is no problem anywhere but the Chromium based applications behave differently.


I think the problem lies in the installed fonts but I cannot figure out where those glyphs are originating from. Any hints?

As a new user I could only post one image in the OP.


Tomorrow, at work, I’ll screenshot my channels there in Rambox.

Actually, these emojis are those also used in the message area and also by Chromium.

Rambox on my work laptop
Rambox work laptop

The icon in the channel Danny has been changed meanwhile.

Okay, I solved the problem. As expected, it wasn’t an error from Mattermost but a Linux font misconfiguration. Arch Linux and Ubuntu required similar but different solutions. In any case, the Noto Color Emoji font needs to be installed.

For Arch Linux it was sufficient to follow this guide, while Ubuntu needed another one.

In case of the latter one, I changed my personal solution to put the config file not in my home dir config but in the system config folder /etc/fonts/conf.avail resp. /etc/fonts/conf.d. First, I tried naming the config 01-emoji.conf but obviously it got loaded to early. After renaming it to 65-emoji.conf it worked. I guess, the solutions with the config in the home dir work because they get loaded after the system config.

1 Like

In the answer I linked there is a reference to an older answer to an older question that I actually used. I mention that because those two answers differ in exactly the naming of the config file.