Config.json keeps being overwritten with the defaults

I’m trying the set up Mattermost with Docker. I’ve done this in the past without any issues across multiple updates on the same machine.

My steps:

  • Clone the repo (5.30 since 5.31+ is broken)
  • Adapt docker-compose.yml a little (edition=team, Traefik labels etc.)
  • Create the volumes directories for 2000:2000
  • Start the containers
  • Adapt volumes/app/mattermost/config/config.json
  • Create users

This always worked fine, but when I wanted to update a few month back I ran into this issue where my config.json just kept being overwritten with the defaults. I could not get it to work and gave up in frustration.

I just tried it again, and it’s still happening. I figured maybe using the GUI will work, so I went through all the settings. When I was done I wanted to add users, so I entered the app container and run mattermost user create ... and immediately Please configure your site URL on the System Console. pops up in my Client and my settings are gone again.

Was there any change why this isn’t working anymore? What am I doing wrong here?

Thanks for any help!