Desktop Application Notification sound not working


Desktop Application Notification sound not working correctly for both Windows and Mac app

Steps to reproduce

Mattermost Team Version 5.9.0
Application version: 4.2.1

Expected behavior

Posts that should incur notifications such as direct messages or @ mention messages should push app notification in Notification Center (or equivalent in Mac) with sound.

Observed behavior

Notification is pushed for 5 seconds as default setting but no sounds is played.
Notification message/sound is working correctly for web apps (tested with Chrome, Safari, Firefox only Safari didn’t work)

What was done?

  • Make sure that Account Settings > Notifications > Desktop Notification Sounds is On.
  • Make sure that Windows Notification Center setting allows notifications message as well as the notification sound.
  • Searched in this forum for similar cases. The only related case found was from 2016 due to a potential issue with Electron No desktop notification using native app on Windows 7

Hi @LuckyLuke192,

What Windows and Linux versions are you on?
Would you be open to sharing your Console errors next time you see this issue? Instructions on how to do so can be found here.

Hello @amy.blais,

My mistake in the original post. We use Mattermost on Windows and Mac application, not Linux. I will re-edit the original post.

Windows 10 version 1709
Mac OS 10.14.4

If it helps, we are also running Mattermost server in Docker and Kubernetes

Console log shows no error:

index_bundle.js:28213 [SOC mattermost] Loading com.github.moussetc.mattermost.plugin.spoiler plugin
index_bundle.js:28213 [SOC mattermost] Loading zoom plugin
index_bundle.js:28213 [SOC mattermost] Loaded com.github.moussetc.mattermost.plugin.spoiler plugin
index_bundle.js:28213 [SOC mattermost] websocket connecting to wss://
index_bundle.js:28213 [SOC mattermost] Loaded zoom plugin

Hi @LuckyLuke192,

On Windows 10, the sound is played by the notification center. Potentially the sound might be muted by some OS settings. Would you be able to check Focus Assist or Notifications & actions settings? Will also investigate other solutions,

Hi @amy.blais,

I have checked that Mattermost allow both Banners and Sounds notifications. I don’t have Focus Assist on this Windows build and I still receive 5s banner so I don’t think it is a problem with focus.

From the console we found the versions of the desktop app:

{http_parser: "2.7.0", node: "8.9.3", v8: "6.1.534.41", uv: "1.15.0", zlib: "1.2.11", …}ares: "1.10.1-DEV"chrome: "61.0.3163.100"electron: "2.0.12"http_parser: "2.7.0"modules: "57"nghttp2: "1.25.0"node: "8.9.3"openssl: "1.0.2n"uv: "1.15.0"v8: "6.1.534.41"zlib: "1.2.11"Symbol(util.inspect.custom): () => {…}__proto__: Object

The chrome version is older than the version of the browser in which sound notification did work. Could it be that the issue is related to electron or chrome version? Or something unintended when using Chrome and Desktop app at the same time? We did try to kill both Chrome and Mattermost process and start only 1 but it didn’t work.

Edit:Updated: My colleague who uses Mac app did have sound notification working after updated the application to 4.2.1. He was using v4.2.0 actually before. My situation on Windows is still the same though.

@wget @yuya-oc Pinging you in case you have additional ideas on the above ^

@amy.blais Thanks for the ping. Please note that for the future, you may also ping Dean Whillier (when he will have an account on this Discourse instance). He has pretty strong knowledge in the app and may answer better than me.

@LuckyLuke192 I cannot reproduce from my side. On Windows, could you please remove the cache in %AppData%/Mattermost and let us know if this works.

Otherwise, we are only testing the desktop app with the latest Windows 10 version. The current one is 1809. The one you have is a bit outdated (except if you are on the Long-term Servicing channel - formerly LTSB -).

1 Like

1709 is not LTSB :wink:


I suggest to upgrade to the latest Windows 10 and try again.

+1 good catch. Didn’t know 1709 wasn’t LTSB :slight_smile:

Hello @wget,

Thank you very much for your input.

What I’ve done:

  • updated Windows 10 to the latest version of 1809 build 17763.437. Double check that the settings in Windows Notification and Settings were not changed.
  • Killed the Mattermost process, uninstalled Mattermost desktop application, backup the data in %AppData%/Mattermost (just in case), deleted all content of inside the Cache folder, then reinstalled the latest v4.2.1 desktop application.

After trying these, I was still unable to hear any sound notification. I am not sure what other debug logs/info I should look into to find the root cause of the problem. Any ideas?

Please login with a new user to your pc. Same problem?

Steps done:

  • Killed Mattermost process.
  • Used Mattermost command line tool to create a new test user, verify and activate.

Tests done:
1 Have another user on another PC send test user a direct message.
2 Have another user on the same PC but on the web app send test user a direct message.
3 Have the test user send another user on the same PC but on the web app. (not related just to experiment)

Only case number 3 produces a notification sound from the browser (Chrome). Both case 1 and 2 did produce pop up banner notification but NO sound.

Edit: I tried to explore the sound settings of my PC and in the Volume Mixer, I see that Mattermost didn’t show up. I think in this case it is the OS fault and I will try to Google the fix for this. What I’ve tried:

  • Enabled “Allow applications to take exclusive control of this device”
  • Ran Mattermost as Administrator
    So far still didn’t work but I feel that I am on the right direction.

Issue resolved. The problem is with Windows notification and sound settings. I attach some screenshots to show what I do to resolve this problem in case someone else is also looking for this


I do not see Mattermost in the notification and action list. Did you had the application there by default or did you add it?

If you did can you share the steps?


I just have the application there after installing the desktop app. Maybe you can try to reinstall the application and make sure your Windows version is updated.

Hope you will be successful in resolving your problem

SOLVED: I had the same problem with MacBook, turns out the notification in MM app was on, but MM notifications for system preference was switched off. Make sure that is switched on for receiving desktop notifications.

1 Like