Help Using Collabora with Mattermost

Hey guys! I’m currently evaluating Mattermost as a Slack replacement. One thing that I’d like to be able to do is collaborate on or edit documents directly from Mattermost. I found the Collabora plugin for Mattermost that I’ve been trying to get working.

I’m new to Mattermost, I’m new to Collabora, and I’m new to Docker, which is running these things. I feel like I’ve stacked the deck against myself! I’m trying to follow the setup for the Code version of Collabora.

I’ve got Mattermost running though Docker and that works fine, and I think I have Collabora Code running fine in Docker too, but I can’t edit documents that are uploaded yet.

This is the command I’m running in the console to run Collabora in Docker.

docker run -t -d -p -e "domain=192\\.168\\.1\\.161:8065" -e "username=admin" -e "password=S3cRet" --restart always collabora/code is the local IP address of my machine. My best guess is that I’m not filling in the domain field correctly, but I’m not sure what’s supposed to go there. Can anyone help me out and shed some light on this? Maybe I’ve got another setting somewhere that I need to set correctly?

Any help is appreciated. Thanks!


I’ve installed Collabora on my Linux server alongside with Mattermost.

After default installation of Collabora, the server want’s to use ssl certificates, so unless you create and configure certificates, you won’t be able to start Collabora server.

What I did is disabling ssl in Collabora configuration file – loolwsd.xml

I don’t know how that works in Docker but try to find out how to disable ssl and try.

Hello, I’m relaunching this discussion thread.
I installed mattermost on a domain and collabora office on a subdomain.
Both are functional.
I uploaded, then activated the collabora plugin in the mattermost console, then specified the collabora address in the settings. A message tells me that the plug-in is activated.
However, when I select a document in the application, it is not edited with collabora.
I can’t think of a way to fix it. No error message.
Help would be welcome. thank you

I think this will only work for new documents that you add after enabling plugin.
You cannot edit old documents.

Hi, thanks for your help. I tested, but it still does not work.

in the mattemost log I find the following messages:

mai 13 14:38:29 mattermost[3518]: {"level":"info","ts":1620909509.3354337,"caller":"mlog/sugar.go:21","msg":"WOPI file info loaded successfully!","plugin_id":"com.collaboraonline.mattermost"}

mai 13 14:38:25 mattermost[3518]: {"level":"info","ts":1620909505.0383484,"caller":"app/plugin.go:286","msg":"Syncing plugin from file store","bundle":"plugins/com.collaboraonline.mattermost.tar.gz"}

Which Collabora version you are using?
I have installed version Collabora Office 6.2-21 on my linux server.
I’ve tried to update to current version 6.4 but that didn’t worked - just like your situation.

collabora version 6.4.4
Mattermost 5.34.2
maybe a setting somewhere, but I have no idea

I can send my configuration changes in loolwsd.xml config file of Colaborra.
I wanted to write down lines where I put some changes after default configuration, but I can’t do it here in this post.
If have an idea how, I could send you my Colabora config file.

Hello, please,
you can send it here → ****
It’s a form on my server.
Thank you very much

I’ve sent you config file.


I looked at your settings, I didn’t see anything different from mine

i reinstalled collabora and the plugin in mattermost, but nothing changes.
back to the starting point.