How to Install Collabora Online Plugin? (LibreOffice)

Hello, thank you for Mattermost.

Collabora Online mentions that there is a plugin for Mattermost.

In my YUNOHOST instance, I do not see Collabora/LibreOffice in the Marketplace.

I tried to implement this file: com.collaboraonline.mattermost-1.1.0.tar.gz with “Plugin Management”
but I can’t upload the file.

It is mentioned:

Enable plugin uploads in config.json. See documentation to learn more.

But the link does not explain this… it speaks about Marketplace.

Thank you in advance for your help (I am not admin).
José

Hi jrd10 and welcome to the Mattermost forums!

Do you have access to the config.json file of your mattermost instance? If so, please change the value for EnableUploads in the PluginSettings section from “false” to “true” and restart your server then.

sed -i -e 's/"EnableUploads": false/"EnableUploads": true/' /opt/mattermost/config/config.json
systemctl restart mattermost

You should then see a file upload picker in the “System console” → “Plugin Management” → “Upload Plugin” control.

Thank you @agriesser

It does not work !

I have lost the plugin Mattermost Boards
I reinstalled it from the Marketplace.

I came back to the previous settings :).

I will wait Collabora in the Marketplace :).

Thank you for your time.

What mattermost version are you using? Maybe the plugin is incompatible with this version?
I can try to reproduce this issue as soon as I know the version.

1 Like

Thank you for tyour time

Mattermost Team Edition
All your team communication in one place, instantly searchable and accessible anywhere.
Mattermost Version: 7.1.2
Database Schema Version: 89
Database: mysql
Join the Mattermost community
Copyright 2015 - 2022 Mattermost, Inc. All rights reserved
[Terms of Use]

Installed with YUNOHOST : GitHub - YunoHost-Apps/mattermost_ynh: Mattermost package for YunoHost

Collabora Online from YUNOHOST
ID : collabora
Libellé : Collabora Online
Description : Suite office en ligne et collaborative, basée sur LibreOffice
Version : 21.11.4.1~ynh1
Peut être installée plusieurs fois : Non
Date d’installation : 11 août 2022 à 09:56:13
URL : …libro.jreservices.fr

Installed with YUNOHOST: GitHub - YunoHost-Apps/collabora_ynh: Collabora package for YunoHost

Thanks. José

Thanks, I could successfully install the plugin version 1.1.0 on my Mattermost setup with version 7.1.2, so the plugin is compatible and works.
Not sure what the special thing about Yunohost is, I never worked with them - do you have SSH access to the server where you installed the Mattermost application so we can check on the logs?

1 Like

Yes.
I use Shell in a Box

With a root account, I can access to the config.json file in yunohost/apps/mattermost/conf/
I modified the file with the Nano editor.

I tried to see with the Zoom Plugin, but it is not the same thing :).

I agree with YNH, perhaps this does not work with this implementation.
See a request here: Collabora Online (LibreOffice) How to get Macros and BASIC IDE (Coolwsd.xml) - Support apps - YunoHost Forum

Thank you for your time.

My mistake.
Never use /etc/yunohost/apps/mattermost/conf/ with YNOHOST.

With YNH, the right place is: /var/www/mattermost/config. (I think)

I modified the file inside this repertory and discarded the previous modification.

But, same issue.

Thank you.

TIL that something like Yunohost exists :slight_smile:

I did spin up a new virtual machine and set up Yunohost on it in order to reproduce your issue.
After I installed the mattermost application to it, I ran the following commands via SSH on the yunohost server:

sed -i -e 's/"EnableUploads": false/"EnableUploads": true/' /var/www/mattermost/config/config.json
sed -i -e 's/"EnableLocalMode": false/"EnableLocalMode": true/' /var/www/mattermost/config/config.json
systemctl restart mattermost

This will enable the plugin upload and the local mode. Local Mode needs a restart, so restart the service then.

Afterwards, you will immediately see the upload button available in system console:

And once the upload is finished, you will see the plugin being listed as available plugin and all you have to do then is configure and enable it:

If this still doesn’t work, please run the following command via SSH and post the output:

tail -100 /var/www/mattermost/logs/mattermost.log
1 Like

Thank you @agriesser I have Collabora activated in Plugins :slight_smile:

In Marketplace > Installed, I have Collabora Online (1.1.0) Local.

The last point, I do not have the “Edit” button close to my xls or ods file in our channels.

How can I access to this command in the channels.

Please, note that the “Collabora Online address” allows to access to a LibreOffice server already used with NextCloud. This Collabora instance has been installed thank to YNH.

Thank you again for your time.

Note: I used the “sed” command I did know instead of to modify the file with an editor.

Great to hear that!

Did you set up the URL for your collabora online instance in the plugin settings? I did not have such a URL, so my logs were getting full of errors about not being able to query the cloud service. Did you put in the correct URL after enabling the plugin? On the FAQ page of the plugin it says that all changes to the settings require a restart of the plugin, so disable and enable it again to see if that helps.

I don’t have an online instance of collabora online and I tried to install it on my yunohost installation, but that’s currently broken as it seems, so I’m not sure waht could go wrong here since I cannot test the integration myself.

Anyways, can you see anything in the mattermost.log file that’s relevant? Can you post the last 100 lines (tail -100 /var/www/mattermost/logs/mattermost.log) if re-enabling the plugin didn’t work so I can look for additional errors?

Also, can you maybe share a screenshot of what you’re seeing? Maybe the plugin is disabling the edit button if the communication with your collabora online server is not working or not properly established.

Hello @agriesser thank you for your time.

  1. Yes, this Collabora (LibreOffice) implementation works because I use it with Next Cloud :slight_smile:
    On this link, I have this message :slight_smile:

This is where Collabora Online is installed. To actually be useful, this needs to be integrated in a front-end such as Nextcloud for example.

See next message (on image by post)

  1. This is the YNH Collabora implementation

Just add it in your YNH instance as an application (by default, not visible in your portal)

Next

  1. For the log, As error message I have a
Worker Failed to fetch product notices "caller" 

(I use Shell in a Box and I do not know how to copy text or file to get it locally)

  1. About .ods file in a channel.

Thank you for your time :slight_smile: José

Hi again and sorry for the long turnaround!

Can you SSH into your Yunohost server where mattermost is installed? Usually, Yunohost allows SSH login with the username “admin” and the password you configured during installation. You can use a tool like putty to connect via SSH to your server, just enter the IP address in the box then and a black window will open where you can type the username and password. Once in, you will need to switch to a root account using su - and then you can access the logfiles. I’ve prepared a screenshot for you, hope that helps:

grafik

You can then just copy and paste the logilnes, make sure to show more logs than in my example, I just printed the last line (-1).