How to stop emails on private messages?

Every time I receive a message on a private chat, an email comes in even though I disabled email notification.

Steps to reproduce
Unclear. I inherited this MM install and trying to get on top of it.

  • Connect to Nextcloud as an admin in a web browser.
  • Disable email notifications, enable push notifications.
  • Have a chat with someone
  • Make sure you don’t flag each other.

Expected behavior
As long as I’m connected, I shouldn’t be receiving any email if I’m not flagged.

Observed behavior
Every time I receive a message, I get both the push notification (expected) and an email (unexpected). This is obviously very spammy.

Hi tech-s and welcome to the Mattermost forums!

What’s the subject and the first few lines of the mail? Is it probably “New Direct Message from @username on $date” and in the body, it says “While you were away, @username sent you a new Direct Message”? If so, the online status detection seems to be broken on your client and Mattermost thinks, you’re away while you aren’t.

Please also check your notification serttings in the client. To do so, click on the gear icon in the top right corner and then on NotificationsEmail Notifications. Here’s a screenshot of what it looks like on my end:

What Mattermost server version are you using?

Hi @agriesser, the subject is in French (“Nouveau message personnel de @@username” = “New direct message from @@username”) but doesn’t read “While you were away…” in the body; it only reads “You have received a new direct message.”. It may have something to do with the current installation that only provides 2 options for email notifications: “Immediately” and “Never”. I don’t have the other two.

May be important to note: since I have to manage two accounts separately (one with admin rights, the other without), the admin account is connected through the Web interface.

Server appears to be the Team edition version 5.26.0. Indeed there are some things that are broken as about half of profile pictures can’t be changed and files cannot be added to a channel.

OK, so this version is very old and we should try to get it updated. First of all, you would have to update to the latest 5.x version which is 5.37.10 as of today, see the Important Upgrade Notes.

Maybe some of the problems get fixed by running the upgrade, at least we should try that before we continue with debugging the issues. Once you’re on 5.37.10, we can then run the upgrade to 7.4.0 directly.