I want to surely display the account creation

I am using Mattermost as an invitation system, and users do not have the option to easily create accounts.
When the first person(know the invitaton URL) accesses Mattermost for the first time, there is a pattern in which account creation is displayed and a login screen is displayed. The user surely accesses with the invitation link. The probability of occurrence is the same on PC and smartphone.

"EnableUserCreation": true,
"EnableOpenServer": false,
"EnableUserDeactivation": true,
"RestrictCreationToDomains": "",
"EnableEmailInvitations": true

I want to ensure that the user who accessed by the invitation URL displays the account creation page. Which setting should I adjust?

Hi @Babbles,

Those settings should work. Also, I think "EnableSignUpWithEmail" should be set to "True" in Authentication > Email.

Thank you for reply.

I also set it to “true”.
This is for PC. The cause may be a character code. Copy the invitation URL and paste it in a simple text editor. And copy the pasted URL. Tell it to users by way of e-mail etc. This method seems to be a registration process for users. We may still only be lucky.

In the case of smartphones, It’s sure that the Mattermost application will be introduced every time we sign in. This is the cause. Is there a way to stop introducing this smartphone application?

The user previously copies the invitation URL to the clipboard. Next, the user once accesses the invitation URL with the smart phone web browser. Then, the user pastes the copied invitation URL into the location bar as it is. The account creation process is displayed.

This step will be difficult for beginners and those with poor computer operation.

A new account can not be created with the smartphone application. (Because I am on an invitation system.) I think that application introduction should not be displayed every time in this state.

Hi @Babbles,

Thank you for the additional details. I understand better what you are looking for - how about if you use the “Send Email Invite” option? If you use that, you would just send an email to the new users and they get directed to the account creation page when they click the link in the email.

This is no longer luck?
I tried it on my iPhone(Safari), another person’s iPhone(Safari). Account creation is displayed and application is introduced. Mailer are Apple Mail, Message.app (iMessage), Web mail service. I tried it with other web browsers(Chrome, iCab, Firefox, ,Firefox Forcus, Sleipnir), but the behavior was exactly the same as Safari.* I do not try Android because there are few Android users around me.

Hi @Babbles It looks like I may have misunderstood what you are looking for - I thought you want users to easily access the account creation page as they access Mattermost for the first time. To clarify, can you help with clear steps to reproduce, the observed (the issue you are seeing), and the expected (what you are looking for)? Screenshots will help as well.

I apologize for misunderstanding!

Even in the invitation email (even copy and paste invitation URL link in email) and the invitation URL, when the user opens to my Mattermost with a smartphone, the Mattermost introduction contents are displayed. Rarely become a registration form.

I want to disable the application introduction.

I think this is the cause. If you deny this, please let me know the workaround. How to make sure the registration form is displayed.

Hi @Babbles! When you say “Mattermost introduction contents”, do you mean the Mattermost login page? If not, can you help share a screenshot of what you’re referring to?

There is no other than the application introduction.

I believe this content is the cause. I want to disable this.

@Babbles What happens if you click on the “Already have it?” link - does it redirect the users to the registration page?

The link destination is the login page for existing users.

A new user needs to paste the invitation URL in the step of introducing the application. The probability of displaying the registration page directly is low.

Hi @Babbles! Thank you for all the information - I was able to reproduce this and created a ticket here: https://mattermost.atlassian.net/browse/MM-11943.

Actually, here is a link to a ticket that was previously opened and it’s marked as “Help Wanted” for anyone who wants to help with a fix: https://mattermost.atlassian.net/browse/MM-10569.