Incoming webhook throws 404 b/c of template error

This is similar to [1] but bear with me, please.

I’m running 2.1.0 (2cd006474ec8a808).

Tried the slack-notifier gem and it was throwing 404 (I had taken the URL from Mattermost and it looked correct.

Tried using cURL with curl -i -X POST -d 'payload={"text": "Hello, this is some text."}' http://mydomain:myport/hooks/123456123456abcdef (taken from [1]) and it also threw 404’s.

Then I saw the reason in the logs:

[2016/03/22 23:52:32 UTC] [EROR] /hooks/deadbeef: code=404 ip=
[2016/03/22 23:52:32 UTC] [EROR] Error rendering template error err=html/template:error.html:4:11: no such template “head”
[2016/03/22 23:52:32 UTC] [EROR] Failed to create error page: html/template:error.html:4:11: no such template “head”, Original error: Handle404: ,

It seems it’s trying to render an error page, so it might be masking another error behind it…

Will keep looking.

– nachokb

[1] Mattermost log error 404 with integration hooks

… just noticed EROR with a single R :joy:

I’m getting this same issue. I’m running from the docker mattermost-dev image. 2.1.0, build 6562, Build Hash 2cd006474ec8a808b2ea2b0502a842f44cb0b127. I launched fiddler and composed a POST right in fiddler to push out to the hook. :frowning:

I filed a Github issue: