Mattermost log error 404 with integration hooks

im getting - - [03/Nov/2015 22:02:01] "POST /new_event HTTP/1.1" 500 - on integration server
and on mattermost in logs is ``: code=404 ip=XXX.XXX.XXX.XXX datetime [ERROR] /hooks/<hook_id>```

Any Sugestion? thanks

This is a 404 or page not found. I think you need something like /hooks/incoming/... or /hooks/outgoing/... vs <hood_id>

Hook addres was copied from Mattermost webhooks … and looks like http://<mattermost-server-address>/hooks/zhr3si9q6jnbpy85ajgap7o3no

One problem I’ve run into is that the gitlab vhost configuration for mattermost does not handle SSL and non SSL. If your site is, anything served from will fall through to the default vhost (gitlab) and most likely give a 404. That may not be your problem, but it’s something to look out for.

Have you tried opening the hook address in your browser? Do you get a 404 there?

I’m dont using SSL.

I opened mattermost webhook addres in browser and get

GitLab Mattermost needs your help:
Sorry, we could not find the page.

sorry there is a route for /hooks/{id:[A-Za-z0-9]+} does your hook_id look valid? should be all alpha numeric chars? otherwise you would get a different error.

You might try deleting the hook and re-creating it.

I recreated link 2 times but there is still same problem…

only a POST type is allowed. Running it from the browser is doing a GET. Try something like curl -i -X POST -d 'payload={"text": "Hello, this is some text."}' http://<mattermost-server-address>/hooks/zhr3si9q6jnbpy85ajgap7o3no

via curl its working but not via integration… returning same error

How are you running the integration? I’m guessing your integration is making a http GET call vs a http POST call.

I followd these instruction when installed it

I had the same issue. My Setup is this:

Hostsystem - Nginx Reverse Proxy for Mattermost and Gitlab)

  • Gitlab Docker Container
  • Mattermost Docker Container

I first installed the mattermost gitlab integration on the Hostsystem, but that didn’t work.

I then installed the mattermost gitlab integration in the Gitlab Docker instance and configured the Gitlab projects webhook url:


and disabled the SSL Verification. That worked for me but i don’t like it.

You can probably set it up on the hostsystem and use nginx reverse proxy for ssl.