iOS Client App v1.9 File Support Disappointing

Hi all,

This is a feature for iOS and iPad(latest firmware v11.4, server v5.0.0), I’ve requested a long time ago. I was very excited to hear it would finally be implemented in the next MM iOS client release(v1.9).
Now it’s out and it’s not working most of the time and not fully implemented.

For iOS or any other platform to fully support files we need three things. 1 send files(upload), 2 get files(download) and 3 view files (file preview).

So when uploading files, most of the time it fails, clearly a bug. You select the file but it doesn’t upload to the server with the following error. (notice that the file contains a reload icon but clicking on it doesn’t do anything).


There isn’t a download button for most of the file extensions. There is a toolbar with close button on the left and download/share on the right side. The download button should alway be available no matter the file extension. (notice at the top, for this file (a picture), the download button is available however in the next screenshot, for a text file, it’s not available).


Most of the file extensions don’t have preview. movies, documents and so on. (notice in the screenshot, a text file is selected and no preview).


Hi @RbDev! Thank you for reporting this.

I’ll be testing this today and checking our Jira tickets if there are other improvements planned.

Hi @RbDev

One question here - can you help with more details on what types of attachments fail to upload? Is there a pattern in terms of size / type?

Hi Amy,

No. everytime fails. there is a 10% chance it will work but it seems to be unreleated to file type or size.

Maybe server connection timeout is to short?


What format types are you trying to upload? To me it does look like a timeout issue, does it always fail at the same progess level?

Regarding video, what format are you trying to play?

For the text file, does it open if you tap on the preview icon?

  1. any file type. fails before progress bar is displayed.

  2. mp4.

  3. tapping on the icon causes it to zoom in.

1 Like
  1. strange, it does work for me without issues (uploading files to pre-release)
  2. it seems that if you upload the file yourself there is an issue playing it back, have you tried cleaning the cache?
  3. will look into it
  1. just tested opening the image first from this post and it also worked just fine

I see what you’ve done in prerelease. I can preview your text file(I dont get preview on my server) but still cant download it.

So I tried adding my own file and it fails with that same error from screenshot 1.

@RbDev A few tickets were opened which we will fix in an upcoming 1.9.2 dot release - I recommend upgrading once the dot release is out and letting us know if file support experience is better: and

Hi @RbDev! v1.9.2 was just released to the app stores and I recommend upgrading!

Hi @amy.blais,

The download v1.9.2 is not available.

@elias showed me that file previews do work on prerelease server but not on mine.

Is it a settings issue? How can I get it to work?


Hi all,

I just got the v1.9.2. upload is looking good. Well done.

I don’t have download option and preview for some of the file types.

Can you help me sort out the preview issue?

Hi @RbDev Of course -

Are there specific file types that you have issues with?
Do you have the same issue in the browser or in other apps that you may be using?
Do the same files work at

@elias showed me that file previews do work for text files on prerelease server but not on my server.

Is it a settings issue? How can I get it to work?


Hi @RbDev! To be honest, I’m not sure. I wasn’t able to find any config settings or other Mattermost settings that could affect this. Perhaps there is an external app or a setting on your phone that could help? I recommend posting about this on our pre-release server on Peer-to-peer Help channel, Native Mobile Apps channel or Developer Toolkit channel - our community and other engineers are most active in the server and somebody might have ideas on this!