MM iOS Client File Preview Not Available

Something already discussed but died at some point.
I can see preview working for some files in the prerelease version but I dont have any in my server.
Why is that? Is it settings missing? is it a plug in required?

Hi @RbDev! I’ll ask our RN team since I’m not sure. Can you help remind me what OS version you are using?

Hi @amy.blais,

I’m using iOS firmware v11.4.1 and MM client v1.10.0, MMserver v5.1.0 too.

It’s funny that logging into prerelease I can see some file previews but not when I’m logged to my server.

Is this a plugin feature? it’s very unusual.


Hi @RbDev - one of our engineers said it might be related to a configuration on your reverse proxy.

I can connect directly using port 8065 and still not get the previews

@RbDev You mentioned it works on pre-release - can you also help check if it works on your browser / webapp?

We are talking about iOS Client, not the browser.

On pre-release server, some files do preview like pictures, pdf, txt and music.

mp4 isn’t working.


But on my server, I get an icon screen.


The issue is: preview doesn’t work on my server like prerelease.

Hi @RbDev,

For this I’m wondering if it’s something to do with the file size - can you help check what your setting is set for max file size:

"FileSettings": {
    "EnableFileAttachments": true,
    "EnableMobileUpload": true,
    "EnableMobileDownload": true,
    "MaxFileSize": 1073741824,
    "DriverName": "local",
    "Directory": "./data/",
    "EnablePublicLink": false,
    "PublicLinkSalt": "gsigbowm6yszrahqyhs4pu7dxiqg9auw",
    "InitialFont": "luximbi.ttf",

@RbDev For this one, would you be able to share login access to your server? You can send a DM to @paul.rothrock on the pre-release server and he can test this out and observe logs / console for any indication why text file preview is not working on your server.

I cant give you access to my prod but I’m trying to get another MM server up.

As soon as I have it stable I will create a test account for you.

Thing is. I cant get S3 bucket to work. I’ve been asking for help longer than 2 months and still not working.

I have multiple servers and they all have this issue.

I don’t know what kind of magic you’ve done on pre release.

the only diference I see is that I dont use nginx. I have mattermost working directly on 443.

@RbDev Yes, I believe nginx is probably why it’s working on pre-release.

Could be but I hope you understand that’s not a good implementation.

All the features should be in mattermost executable.

nginx should work only as a tool to redirect access to mattermost service

Hi @RbDev, my colleague will help test this and try to replicate - I’ll let you know if he’s able to see this issue.

Hi @amy.blais. Is there someone online who can help me identify this issue?

Thanks for following up,

My colleague was working on setting up a test environment to test it - I’ll ask him what the current status is.

Ive created a test environment with the issue.

I can give him access.

Thanks, can you help provide account details on the test server on pre-release - you can open a Group Message with me (amyblais) and my colleague (paul.rothrock).

I’m still facing this issue.

It is really disappointing not to be able to use the files uploaded.

Can we raise the priority on this one a bit?