iOS Client Movie Support (iOS v1.7.0)

iOS app v1.7.0 displays thumbnails for pictures fine.
Unfortunately the same doesn’t happen for movies(.mov, .mp4). An icon appears but you cannot preview, watch nor download the video.
Is this feature not available or does it need a fix?

What version of Mattermost server are you using?

Mattermost Server: 4.7.3

Could you try upgrading to the latest version of Mattermost to see if that fixes it?

Also, do you see any errors in your Mattermost log when you upload or attempt to download the videos?

I could update but I don’t see how this issue is related to the server.
I do believe the feature hasn’t been implemented in the iOS client app. Just like other file types that has no support. not even the option to dowload.

The log doesn’t contain any errors.

@RbDev Following up on this - are you still seeing issues with movie uploads? If yes I will queue this for our engineers to take a further look.

We also recently released a new iOS version (v1.8.0) - if you want to you can try upgrading to see if you find anything different.

just to clarify. I can upload movies but there is no preview feature.

a simple icon appears. it doesnt even allow to download.

I’m using version 1.8.0.

Screenshot of the app


This sounds like a bug, @elias can you help confirm? I can then create a ticket.

@amy.blais can you try and repro this? I just tested and it all worked just fine for me

@RbDev Have you tried re-installing the Mattermost app? Would you be able to check if movie previews work on any other apps that you might be using on your phone?

reinstall in iOS? you must be joking.

no it doesn’t work on multiple iphones, ipad and browser.

None of them work.

Mattermost client displays the media icon.

Mattemost Classic client displays a crash icon and logs out.

The browser displays the crash icon and gets stuck.

@RbDev Have you tried this with different servers? You can register on our pre-release server to test it if you don’t have another server to use.

pre-release server also crashes.

Screenshot of the browser

Okay, I’m able to reproduce this as well. I’ve created a ticket in Jira to have this investigated by a dev. Thanks for helping us squash this bug!

I am also having this issue. I tried logging into our mm server from chrome on my iphone and it also could not play the file. Thanks for looking into this.