Jira plugin 400 Bad Request WebhookEvent missing

Hi All.
I have a question for jira integration.(mattermost 5.90 , jira 8.0)
I do on the guide:


Integration did not work.

When checking POST request, I got error 400
curl -v --insecure “https://xxx.yyyy.com/plugins/jira/webhook?secret=AmbETIDb1ARpypv9TfFFoLplmsrEBByF&team=zzz&channel=jira&user_id=admin&user_key=admin” --data ‘{“event”:“some_jira_event”}’

  • Connected to xxx.yyyy.com (aaa.bbb.ccc.ddd) port 443 (#0)
  • successfully set certificate verify locations:
  • CAfile: none
    CApath: /etc/ssl/certs
  • SSLv3, TLS handshake, Client hello (1):
  • SSLv3, TLS handshake, Server hello (2):
  • SSLv3, TLS handshake, CERT (11):
  • SSLv3, TLS handshake, Server key exchange (12):
  • SSLv3, TLS handshake, Server finished (14):
  • SSLv3, TLS handshake, Client key exchange (16):
  • SSLv3, TLS change cipher, Client hello (1):
  • SSLv3, TLS handshake, Finished (20):
  • SSLv3, TLS change cipher, Client hello (1):
  • SSLv3, TLS handshake, Finished (20):
  • SSL connection using TLSv1.2 / ECDHE-ECDSA-AES128-GCM-SHA256
  • Server certificate:
  •    subject: CN=xxx.yyy.com
  •    start date: 2019-03-24 23:22:44 GMT
  •    expire date: 2019-06-22 23:22:44 GMT
  •    issuer: C=US; O=Let's Encrypt; CN=Let's Encrypt Authority X3
  •    SSL certificate verify ok.

POST /plugins/jira/webhook?secret=AmbETIDb1ARpypv9TfFFoLplmsrEBByF&team=xxx&channel=jira&user_id=admin&user_key=admin HTTP/1.1
User-Agent: curl/7.38.0
Host: xxx.yyy.com
Accept: /
Content-Length: 27
Content-Type: application/x-www-form-urlencoded

  • upload completely sent off: 27 out of 27 bytes
    < HTTP/1.1 400 Bad Request
    < Content-Type: text/plain; charset=utf-8
    < X-Content-Type-Options: nosniff
    < Date: Mon, 25 Mar 2019 21:13:59 GMT
    < Content-Length: 21
    WebhookEvent missing

Hi @Ruflex,

Would you be open to sharing your Jira settings in JIRA > Webhooks, as well as your Mattermost Jira plugin settings in the System Console?

Hi @Ruflex,

Your request body could be missing a required key - webhookEvent .

Try to check the board share permission. I had the same issue, but resolved it by giving the correct permission to access the board

Yes, everything is set up as in the instructions. Even more, integration has partially earned. This is manifested in that in the mattermost began to appear posts on the creation of tasks and subtasks:


But the changes and comments are still not working, for the same reason. The same error in the log:

{“level”:“debug”,“ts”:1553279684.0300117,“caller”:“app/plugin_api.go:650”,“msg”:“Failed to serve HTTP request”,“plugin_id”:“jira”,“Error message”:“WebhookEvent missing”}

Hi @Ruflex, Would you be open to joining our Peer-to-Peer Help channel on our community server for more help on this issue?

I’m not sure what the solution is and I haven’t received feedback from our team in the past few days on this yet.