Jira plugin not posting

For feature requests, please see: http://www.mattermost.org/feature-requests/.

For troubleshooting questions, please post in the following format:


Jira create/update/delete actions are not posting to mattermost, curl test works and returns 200 per FAQ

Steps to reproduce

configure jira(7.12) and mattermost (5.4.0) per documentation, create issue, no post in MM, close issue, no post in mm, separately tried to add as a workflow post function, still nothing

Expected behavior

Post message to configured channel via url

Observed behavior

nothing happens, nothing in debug logs, even when I curl the URL.

Hi @dcarter,

Did you take a look at the tips in the troubleshooting section already: https://docs.mattermost.com/integrations/jira.html#why-doesn-t-my-jira-webhook-post-any-messages?


Yup that’s why I ended up on the forum.

I copied the exact URL created and used it for the curl example in the troubleshooting, I’ve tried with multiple different users, regenerated the secret. I even put the wrong url details in on purpose to make sure it was actually validating the data and it is. I’ve updated config and restarted several times, I’ve ensured that the plugin exe file is running (confusing name for a Linux binary?), everything else about the server is running fine that I can see. The plugin is definitely not logging anything though, I’ve also enabled debug logging for plugins and nothing appears in the log file.



Hi @dcarter,

The issue may be related to the relative path in the Plugins configuration. Can you change the following:

Change PluginSettings>Directory to /opt/mattermost/plugins
Change PluginSettings>ClientDirectory to /opt/mattermost/client/plugins

Then try uploading a plugin and see if that works.

Have already tried this per the below;

"PluginSettings": {

    "Enable": true,

    "EnableUploads": true,

    "Directory": "/opt/mattermost/plugins",

    "ClientDirectory": "/opt/mattermost/client/plugins",

    "Plugins": {

        "jira": {

            "enabled": true,

            "secret": "removed",

            "username": "removed"



    "PluginStates": {

        "jira": {

            "Enable": true




I also updated the running directory in the start script too.

Hi @dcarter,

What OS and version are you on?
Also, are you using Nginx and if yes, do you see any issues in the SSL certificate?

RHEL7.5, we are using NGINX, but no SSL errors.

Hi @dcarter,

The path ./client/plugins is relative, make sure that the Mattermost binary’s working directory is /opt/mattermost and not /opt/mattermost/bin or another directory.

Try setting the config values to the full path and restart to see if that resolves the issue. If not, see if you’re able to create a file in those directories like this:

$ sudo su mattermost 
$ touch /opt/mattermost/plugins/test
$ touch /opt/mattermost/client/plugins/test