Jitsi Meet Plugin - No video, No Sound

Hi all,

straight to the issue. We are using:

  • Mattermost Team Edition, self hosted on a NAS
  • only people within the LAN and those connecting to it through VPN can access it
  • Mattermost is working fine as a container inside Docker


  • Jitsi Meet was installed but is not working. I tried having it open i na new tab, inside the Mattermost embeded window, but whenever I hit “Join meeting”, no matter if it opens inside the embeded window or in a new window, if inside the desktop app of Mattermost or in a web browser, all we get is a gray screen and nothing happens. No audio, no image.
  • I tried disabling the firewall on the NAS but no progress

What do I have to do?
Do I have to install the Jitsi Meet as a container in Docker for to be able to use it inside Mattermost as a plugin? That makes no sense to me but I could be wronf (fairly new to Docker and Mattermost)
What should I put inside the field “Jitsi Server URL”? Currently, there is http://local-ip-of-the-nas. Is this correct? I tried changing to https://meet.jit.si but no progress with the issue.

Reminder: Jitsi will be used only to attend meetings with remote co-workers who connect to the LAN via the VPN. So my reasoning is that the Server URL should be the IP of the NAS on our network and that we don’t need to add anything to those Authentication fields in the Jitsi configuration (below the server url), but I might be wrong.

Thanks in advance!

Hi Mart1r,

I think we first need to find out why your Jitsi deployment is not working alone; once you are able to login to Jitsi and do something with it (you can use Jitsi without mattermost, start a meeting there, etc.), we can then work on the integration part with Mattermost.

What kind of NAS is that? Synology? If so, what version of Jitsi Meet did you install? Usually the port will be different because there are several applications running on your NAS, so most likely you will have to configure the port where Jitsi runs somewhere in the deployment of the app on your NAS and you will then have to connect to a port like http://local-ip-of-nas:8080 (or whatever the port ist).

Although, strictly speaking, this has nothing to do with Mattermost, but let’s see, maybe it’s an easy one :slight_smile: