Local file storage on mounted volume has issues

I have a mounted volume attached to my Mattermost server. Its location is /mnt/volume_name/. I have tried setting the file storage location to


in the system console, but mattermost ends up creating /opt/mattermost/mnt/volume_name/data and saving data there instead. Does the local storage data folder have to be a child of /opt/mattermost? I also tried …/mnt/volume_name/data to force it to go up a directory unsuccessfully.

Hi unrelatedwaffle and welcome to the Mattermost forum!

Can you confirm that there’s no . in front of the path in the value in system console?
What Mattermost server version are you running and what deployment model (binary, omnibus, docker, etc.) did you use?
Please also post the output of the command jq .FileSettings /path/to/your/mattermost/config/config.json.

Hi agriesser,

There is no . in front of the path in System Console.

I’m running version 7.5.1 with a binary deployment model.

Output of jq command:

  "EnableFileAttachments": true,
  "EnableMobileUpload": true,
  "EnableMobileDownload": true,
  "MaxFileSize": 52428800,
  "MaxImageResolution": 33177600,
  "MaxImageDecoderConcurrency": -1,
  "DriverName": "local",
  "Directory": "/mnt/volume_nyc1_01/data/",
  "EnablePublicLink": false,
  "ExtractContent": true,
  "ArchiveRecursion": false,
  "PublicLinkSalt": <redacted>,
  "InitialFont": "nunito-bold.ttf",
  "AmazonS3AccessKeyId": "",
  "AmazonS3SecretAccessKey": "",
  "AmazonS3Bucket": "",
  "AmazonS3PathPrefix": "",
  "AmazonS3Region": "",
  "AmazonS3Endpoint": "s3.amazonaws.com",
  "AmazonS3SSL": false,
  "AmazonS3SignV2": false,
  "AmazonS3SSE": false,
  "AmazonS3Trace": false,
  "AmazonS3RequestTimeoutMilliseconds": 30000