Mattermost not working on VPN

Hi Team,

Summary of problem-
Mattermost becomes read-only and push notifications are not working on internet but working fine with VPN.

  1. Mattermost Version: 6.0.1

Hi Shikha,

I’m afraid I will need a few more details here, sorry.
Where is mattermost running? did you install it on a server or on your computer? What installation method did you use? Docker or Standalone or anything else?
The push notifications itself are handled by the server directly, so the server component is connecting to the internet (i.e. and is sending the push notifications there, so the only reason why this could not be working is that your mattermost server is not able to connect to the internet (or there is some kind of SSL interception or the like that cause problems with that).

Can you send a screenshot of what the system looks like when it’s ready only? Are only specific channels being switched to read-only mode or is it not possible to post anything at all? You could try to send a direct message to yourself (just open a direct message channel with your username) - is this also not possible then?


Mattermost is running on server installed Docker instance.

All channels are switched to read-only when not connected to company’s VPN, and it’s impossible to send direct messages to ourselves either, as input window doesn’t appear at all.

Thank you for your help

Hi MSudol,

thanks for the additional information, I’m still trying to reproduce that or find configuration options that could be related, but until now I failed to do so.
Does this also happen when using the webclient? If so, can you maybe have a look at the browserlog (developer tools) to see if any of the requests are timing out when disconnected from the VPN?
I’m not aware of any functionality that would result in what you’re seeing, but I’m still looking.