Mattermost Notification stopped working after upgrading to 5.33 version


We are facing an issue with the Mattermost notification not working after upgrading to the version 5.33 community edition. The email notification and the desktop push notifications are not working now. Earlier this was working fine but after the version upgrade this stopped working. I have checked and confirmed that the email from the server is working fine by sending test email from the Mattermost test email option. Please let us know what is causing the issue with the upgrade. TIA.

Hello, @Sandeep

Since you mentioned that the issue occurred specifically after the upgrade, I would suggest us to check on the mattermost.log and trace the log for any errors related to notifications and we can start from there. You can remove any sensitive information and share it here for review.

Meanwhile, you mentioned that the desktop notifications are not working. While this may be client side specific, can you explain more on what is broken in the desktop notification? Is it configured to look like this?

Hello @ahmaddanial ,

Thank you for the update.

I have gone through the ‘mattermost.log’ file and found the notification string as mentioned below. I have replaced the host, ID etc with ‘*’.

{“level”:“debug”,“ts”:1619******.57*****,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“POST”,“url”:"/api/v4/notifications/ack",“request_id”:“",“host”:"..",“scheme”:"",“status_code”:“200”}
,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“POST”,“url”:"/api/v4/notifications/ack",“request_id”:"cqb4mw*”,“host”:“..***”,“scheme”:"",“status_code”:“200”}

Also on tailing the recent logs i could see the following entries as below.

{“level”:“debug”,“ts”:1620012271.8044384,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“GET”,“url”:"/api/v4/users/me/teams//channels/members",“request_id”:"**",“host”:"..",“scheme”:"",“status_code”:“200”}
{“level”:“debug”,“ts”:.,“caller”:“mlog/log.go:211”,“msg”:“CSRF Header check failed for request - Please upgrade your web application or custom app to set a CSRF Header”,“path”:"/api/v4/users/ids",“ip”:“IP”,“session_id”:“",“user_id”:"”}
{“level”:“debug”,“ts”:.,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“GET”,“url”:"/api/v4/users/me/teams/unread",“request_id”:"",“host”:".**.",“scheme”:"",“status_code”:“200”}

Regarding the notifications, I have confirmed that the settings is as shown in the screenshots above and the push notifications for chat and the also the email notification was working fine before the upgrade.

Thank you in advance.

Hello, @Sandeep

The 200 OK shows that the requests are successful. Can you confirm if you have notifications.log in the same directory as mattermost.log so we can dig deeper into this?

When you mentioned that the desktop notifications is not working anymore, can you explain if you are referring to the pop up notification that appears on the top right / bottom right of the screen?

As for email notifications, are the users on the offline or away status when they are expecting the email to be sent based on the description on the app?

Email notifications are sent for mentions and direct messages when you are offline or away for more than 5 minutes.

Hello, @ahmaddanial

Thank you for the update.

Yes, I have the mattermost.log and the notification.log in the same directory. Could see the below logs in the notification.log file also.

{“level”:“debug”,“ts”:.,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“GET”,“url”:"/api/v4/channels//posts",“request_id”:"m9p5h",“host”:"",“scheme”:"",“status_code”:“200”}
,“caller”:“web/handlers.go:104”,“msg”:“Received HTTP request”,“method”:“POST”,“url”:"/api/v4/users/status/ids",“request_id”:“",“host”:"**”,“scheme”:"",“status_code”:“200”}

Yes, The push notifications in desktop. I could see the chat when i access Mattermost but even if i am using any other application i was receiving the chat as popup from the application which is not working right now.

Also, The email notification is also not working for any of the options. I have tried changing the different options and have set immediate email option for chats also. But is is not working. I have test the SMTP option from the Mattermost and received the test email which confirms that the email functionality is working fine. Both the mentioned notification options were working fine before the upgrade.

Hello @ahmaddanial

Any options that we could check to fix the notification issue in Mattermost. We could see that the email functionality is working fine from Mattermost when tested with the email test option in Mattermost but the notification email is still not received. Also the pop notification is not working on the Desktop as mentioned earlier.

Thank you in advance.

Hello @ahmaddanial

I have upgraded the Mattermost version from 5.33 to 5.34 version and could see that the notification is working fine now. Thanks for the support.


Hi @Sandeep

Sorry for the radio silence as I was occupied with tasks on my end. Thanks for confirming that the notification works again after the upgrade!

I’m curious what version you were on before the upgrade? I’m not able to get desktop notifications to work on 5.32, so I’m curious if that version is also effected. Thanks.

1 Like

Hi, @maudette

Would you mind sharing more information on the issue that you are facing here?

  • Is it affecting all the users who are using the Mattermost desktop app?

  • How is the configuration of the desktop app notification look like on your end?

  • Which operating system are you running the desktop app from?

  • Is the notification working on the web browser?

We only have a few users using Mattermost right now, but yes it’s affecting all users. Mattermost is running through a GitLab omnibus docker install 13.10 (so using Mattermost 5.32). We’re accessing Mattermost through Firefox 78.9.0esr. Desktop Notifications settings are “For all activity” and the channels settings are global. Firefox is running on Centos 7.

Hi, @maudette

Got it. So, the notification is just not working for both web browser and desktop app, right?

Let us take a look at the desktop notification chart here:

Can you go through each flow and let me know if everything checks out?

Yeah I’ve looked over the flow chart a bunch of times. It should all checkout and jump right from “For All Activity” to “Trigger a desktop notification”. I’ve also confirmed other notifications work from Firefox.

We’re not using the desktop application, just browser.

Hi @maudette , I was using the Mattermost 5.33 in which I had the notification issue. I have updated the version to 5.34 and the issue was fixed.

Yeah sorry, I meant what version were you on before 5.33?

Yes, it was 5.33 version and i updated to 5.34 version. Before that i was using 5.26 version which was working fine, But after upgrading from 5.26 to 5.33 version i faced the notification issue and when i updated to 5.34 version it is working fine.