Message kept in the "sending" state


I started using Mattermost with my team today. It seems like a great tool, however I already encountered a bug.

I was typing a message, and when I clicked “send”, the message went into the “sending” state (with the little loading animation on the right), but the message seemed to be stuck there. I reloaded the page, and then my message was duplicated, once in the “sent” state and the other one still in the “sending” state.

I tried to clear the cache, reload the page, even restart the server with no success so far. What can I do to remove the message in the “sending” state ?

Thank you !

Hi @ergo_404, can you let us know:

  1. Which version Mattermost you’re using, and if you upgraded recently (Main Menu > About Mattermost will tell you the version)?

  2. What browser are you using?

There was a bug reported in Mattermost v1.1.0 with Safari 8. Mattermost v1.2.1 now requires a minimum version of Safari 9 and we’re not seeing the issue any more.

I am using Mattermost 1.2.1 and I’m seeing this issue on Chrome 46.0.2490.86 m
When this issue happened my network wasn’t working properly, so I wouldn’t be surprised to see that this was caused by a disconnection while sending the message.

I also just tried it on Firefox and I’m not seeing the issue on that browser.

Can you clear your bowers cache? It should cause it to go away. I think this might be a leftover issue from 1.1.

I already tried that. I did it again on Chrome (Settings => Clear Browsing Data and selected “images and cache”) but it didn’t work, I still have this message showing up.

However this is not a big deal for me, I just wanted to warn you for the potential bug. Thank you !