Mobile app shows all channels as "read-only"

Hey all,

This morning I noticed some unusual behavior with the mattermost mobile app (version 1.30.0). Every single team/channel will not allow me to send messages, stating that the channel is “read-only”. The desktop app and browser all work as expected, its just the android app that gives this issue. No changes have been made the the server config recently.

Has anyone else experienced this? If so, any idea about what the cause could be?

1 Like

What Mattermost server version are you on?

Looks like server version is 4.8

Would you be open to upgrading your server version? v4.8 is not an officially support version anymore. We support versions v5.19 and later.

Yeah, it’s been something I have been meaning to do. Is updating somewhat simple? Is there a good guide you reccomend?

Our upgrade guides can be found here:

One of my users has this problem with my 5.21 TE server (app version 1.30.0).

Logging out and in again fixed it for him though, but since TE does not have read-only channel this seems to be a bug nonetheless.

Another user reported this as well, and mentioned that he tried to access Mattermost while the database was down for maintenance reasons.

Fix is coming:

Just wanted to follow up on this if anyone else is having similar issues.

I was getting “This channel is read-only” in every channel on android mobile app version 1.30.0 while running mattermost server version 4.8.0.

This was fixed almost immediately when I upgraded mattermost server to version 5.21.0.

1 Like

Mobile v1.30.1 dot release has been released and will be available in the app stores soon.