Problems with Mattermost iOS 1.4.0 (iOS 11.1)

After updating to version 1.4.0 on iPhone 7 Plus with iOS 11.1, I am stuck with an endless spinner and a crash when the app is force closed and relaunched. Our MM server is on version 4.

Hi @robby.andrews can I ask you to try something? I just want to confirm an issue and if that’s the case it will help us a lot to solve it.

Can I ask you to login with the desktop/webapp and remove all your DM channels and then try again? I know is a pain to do, but if that is the issue we might have a fix released soon :wink:

Thanks for your help.


I removed all DMs, uninstalled the app, reinstalled and am still not able to use the app and am stuck loading. I also filed a github issue with screenshots.

Ok what about unfavorite all the channels?

i removed all channels and dms but still no luck.

Wanted to add that I upgraded to iOS 11.1.1 and this didn’t correct the issue. I’m still using Mattermost Classic for the time being.

We’ve release a patch yesterday can you try with that one? Version 1.4.1 is available on the store

1.4.1 is working on now. Thank you.

I’m glad this is now working for OP, but as of 1.4.1 we are having the original problem posted here: just spins trying to connect to our server, then crashes. In both 1.4.0 and 1.4.1 we are also getting no response when tapping any of the controls at the top of the screen (iPhone 6).

What version of iOS are you on? I have a github issue that I closed but if you want to add on here’s the link:

@davee3db - were you also seeing that issue in v1.4.0, or is it new in v1.4.1?

The app should now be pinging your server to check for a connection, so not sure what would be causing the issue now.

A few questions:

  1. To confirm, accessing the server works fine from desktop? Would you know if people with Android devices are having the same issue connecting to your server?
  2. Are you on an air gapped network? Do you use a mobile VPN to connect to your server?

Can you also try uninstalling and re-installing the app, in case something with the cached data is causing an issue?

I am on iOS 11.1.1. I will add to the github issue.

I was not having the connection issue in 1.4.0. The issue of unresponsive top menu bar was in both 1.4.0 and 1.4.1. Desktop app works fine. I am on the local network.

Good news: uninstalling and re-installing the app resolved both issues! I will let our team know to try that. Thanks!

Okay great, glad to hear it! I’ll let our team know re-installing fixed the issue, to see if anyone has ideas on how to fix it in case others hit the issue.

Is it work for mobile recorder?