New member invitation link is invalid

For feature requests, please see:

For troubleshooting questions, please post in the following format:

Issue in one concise sentence
Hi, I’m new here and I’m not very technical. I migrated to Mattermost when I found out Slack is going to charge us to access older discussion threads.

I created a server, and so far I really like it. But when I tried to invite another member (I tried to invite myself as a test case), the link I received turned out to be invalid. Why is this?

Steps to reproduce
I used the web version and I just clicked on “invite members” on right hand column menu toward the bottom.

Expected behavior
The invitation link I received takes me to a webpage, but when I type in email address, username and password and click submit, I get an error saying that the invitation I used is invalid.


Hi @manatees74 and welcome to the Mattermost forums!

This usually happens when you click on a link while being logged in to Mattermost. Do you have a second browser or a second computer where you can try to access the link after you copied it or sent it to you? Alternatively,before opening the link, logout of your Mattermost installation and then the link should work and take you to the registration page.

Hi paajnjii2 and welcome to the Mattermost forums!

Can you please rephrase your question? I’m afraid I do not understand :frowning: