(SOLVED) Problem with inviting links after mattermost updating

Hi Mattermost cummunity,

I have updated the Mattermost from 3.6.0 (3.6.2) to 4.0.0 (4.0.1). Now when I try to invite new user I got next error page when trying to join team:

I have used this guide to do the upgrade: https://docs.mattermost.com/administration/upgrade.html

Thanks in an advise.

Thanks for your feedback @ally,

I’m not able to reproduce your issue on the latest version so perhaps it’s an issue with the upgrade itself.

I’ll ask one of our devs for their help to get your issue sorted.

Hello @lindy65

Thank you for your feedback.
I have enabled the log level into debug mode, but did not get an useful info from there.

May be you have some tip(s) of where to start to try to find the cause of the issue?


Hi @ally,

Apologies for the delay,

I haven’t had feedback from our devs yet as they’ve been quite busy with v4.1 which releases 8/16.

Can you tell me which method you’re using to invite a user to the team?

  • get team invite link?
  • send email invite?

Could you check the “Team Settings” (3-bar main menu > Team Settings) and let me know whether your team is an open team - i.e. anyone on the server can join.

Also, if anyone has generated a new Invite Code since the invite link was sent out, the link will be invalidated and a new one will need to be sent.

Does this help?

Hello @lindy65,

Thanks for the answer.

Unfortunately it did not help.
I tried both methods i.e. ‘team invite link’ and ‘send email invite’. Both do not work.
The e-main invintation message is sent well and I got it immediately and when I click on ‘Verify Email’ it redirects me to “Page not found” page.

I tried to re-generate “Invite Code” and also the
"Allow any user with an account on this server to join this team" setting is set to - yes.

Hmmm… Thanks for the feedback @ally

One other thing to check is that the server URL is set in the >System Console >SETTINGS >GENERAL >Configuration >Site URL.

Let me know if this helps. If not, I’ll ask one of our devs to step in and help troubleshoot.

Hi @lindy65,

I am sorry for been incompetent. You are absolutely right. The Site’s URL contained additional characters in the URL, that led to the wrong e-mail invitation URLs.

Thank you very much!


No worries at all @ally!

Feel free to stop by any time if there’s anything else you need :slight_smile: