No Notifications on Android (LineageOS17)


I have recently set up a Mattermost server for my friends and myself. Unfortunately I am currently facing a strange problem.

I received a message that there are no push notifications on my friend’s phone. He uses an Android phone with LineageOS 17 ROM without any Google services.

He has both Mattermost Apps (Mattermost & Mattermost Beta) installed. But he does not receive any notifications on either.
On my Android phone, as well as on all others, everything works. Also the desktop clients work correctly.

Other apps notify him normally. It’s only the Mattermost apps that don’t work.

He has already reinstalled the apps several times and cleaned his active sessions before every reinstall.

We have also already checked his Android permissions and battery settings. They are consistent with other working apps.
can this be a problem of missing Google services?

is there anyone who might be able to help me with this?
Thank you very much.

Have you tried the troubleshooting docs

Hi Amy,
Thank you very much for your reply. Yes, I have already performed every step of the troubleshooting doc. Unfortunately I have not received a debugging log for his device.
If he issues a test push in his app, it works as intended.

So I thought it might have something to do with the missing Google services. I can’t find anything on the web whether mattermost is using the Google services or not.

but I can restart the whole debugging process at step 2 of the document.

Could either of these docs help?

Hi Amy,
thank you again. I do not use a special push server. i have installed the free version and use the free test push server, nor have I made any special settings. TLS is enabled and runs with a Let’s Encrypt certificate.

The push should only include Generic description with sender and channel names. And it works correctly on 9 of 10 devices (Android/iOS). The only device that does not work is my friend’s LineageOS Android. All other notifications work fine on his device.

I have a small update.
since my last answer my friend has completely deleted his phone and installed the new version LineageOS 17.1 Stable (Android 10).
He has deleted every Android app from his active sessions and installed the app completely new.
Unfortunately he still doesn’t receive any notifications. After that we tried every available mattermost app (mattermost classic & mattermost beta from the fdroid store as well as mattermost&mattermost beta apk from the google play store). but unfortunately he still doesn’t receive any notifications.
His older phone and his windows client, still get all notifications.

we have checked all notifications and app-specific settings, but it looks exactly the same as on his other phone. the test notification, which is issued by the app itself, also works as it should.

since the app is available in the f-droid store, i don’t think it has anything to do with the missing google play services. unfortunately i can’t find out what’s wrong.

is there anything else i can do?
Thank you very much.

Would you be open to sending youe notifications.log file?

sure. should I copy the whole file in here or can I upload it somewhere?

You can paste them here or you could save them in a onedrive and paste the link to it here.

The file is quite large. I therefore share it via my Nextcloud. The second file contains the affected user-/session ID. Unfortunately I do not know how to find out the device-id.

Today he updated the app to the latest version. Unfortunately, he still does not receive any notifications.

@paulrothrock @ahmaddanial Would someone on support be able to help take a look at the logs?

Hello, @gecc0

I could not access the log anymore from the original links provided:

I would like to understand if this is a environment specific issue or rather an account specific issue:

  • Are you able to log in to your friend’s phone and receive push notifications? Vice, versa is your friend able to log in to your device and receive push notifications?

  • How does his notification setting look like on the Mattermost app and OS level?

Since you mentioned the following:

Did you attempt to test the push notifications using the steps in the Testing Push Notifications? If yes, did you test it for all activity and for every status (Online, away, or offline)?

Hello ahmaddanial,

Thank you very much for your answer. It looks like these links expired after 7 days. I have shared them again without a expiration date.

To your question: It looks like it has nothing to do with his account itself. If we use his account on my device, he will receive all notifications. If I use my account on his device, I don’t receive any notifications either.
We also tested an account from another server (the second server was not set up by me). With this account he couldn’t get any notifications either, but it worked on my devices.

It uses exactly the same notification settings as I do.
Send notifications: For all activity
Trigger push notifications when: Online, away or offline
Send desktop notifications: For all activity

Yes, we followed the “Test Push Notifications” document, but he only received push notifications when I pressed the “Send me a Test Notification” button directly in the app itself.
As mentioned before, we tried every app we found (mattermost, mattermost classic, mattermost beta) with the same results.

from any other app on his phone he receives all notifications as expected.

are there any new updates about this issue?
Unfortunately, it looks like it is still not solved with the newest app release.

@ahmaddanial Do the logs above help or should we ask the Mobile team to help?

Hi @gecc0

Sorry for the delayed response. I went through the response you provided here and believe that it is an environment specific issue:

I tried to access the links you shared since you mentioned that you have removed the expiry date but I am getting this on my end.

@amy.blais This sounds like an issue specific with Lineage OS since @gecc0 mentioned that it is working on his device when the affected user logs in. It is best to get the mobile team involved since I do not have the Android device with the same OS to test it on.

Hi @ahmaddanial,

Thank you very much for your answer. Could you please try again to access the files? The URL was not accessible due to maintenance last night. It should be working by now.

From an outside perspective I think this is actually the core of the problem.

Mattermost uses Firebase Cloud Messaging to relay notifications to mobile devices. Without Google services installed you afaik do not have access to these on Android.

1 Like

Hello, @gecc0

Went through the logs and traced back the first occurrences for the user ccs81wigebfu7gpg7dnn79h86y as I could not trace any information based on the failed session ID:

  • Failed notifications - Thursday, 5 March 2020 13:40:58.327:
{"level":"warn","ts":1583415658.3273983,"caller":"app/notification.go:261","msg":"Notification not sent","logSource":"notifications","ackId":"","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"t8e9m68zb7gmmmjtkykzio5jkw","status":"Not Sent due to preferences"}
{"level":"warn","ts":1583485845.3320816,"caller":"app/notification.go:293","msg":"Notification not sent","logSource":"notifications","ackId":"","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"xbsmiudmxi84bq15w93renfhja","status":"Not Sent due to preferences"}
{"level":"warn","ts":1583485845.3965795,"caller":"app/notification.go:293","msg":"Notification not sent","logSource":"notifications","ackId":"","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"8emmg56kwfnmtdtqfpmgoqwrfr","status":"Not Sent due to preferences"}
{"level":"warn","ts":1583485845.6390758,"caller":"app/notification.go:293","msg":"Notification not sent","logSource":"notifications","ackId":"","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"4jgfxrii6ir43qzcy54q1jr7wc","status":"Not Sent due to preferences"}
  • Successful notifications - Wednesday, 8 April 2020 13:40:06.655
{"level":"info","ts":1586353206.6559262,"caller":"app/notification_push.go:321","msg":"Notification will be sent","logSource":"notifications","ackId":"8t7yjcc173nfdd9h7uykt6xy9h","type":"clear","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"","status":"Prepared to send"}
{"level":"info","ts":1586353207.208887,"caller":"app/notification_push.go:128","msg":"Notification sent","logSource":"notifications","ackId":"8t7yjcc173nfdd9h7uykt6xy9h","type":"clear","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"","channelId":"r6zngex9pff8dykjtq63b4paae","deviceId":"fp6yDJi01h8:APA91bGm7zSXgccwkYAJshGZaRUkpUGKbiITm5GtMJoJLZWkfidKtX71rlZF71DAAeeaBKzcasaIcGslug6KMaNe4mRMwmMPBMMKRAC5GIfn-CnDwtZdIkukyraih_DebJ3FRLkbHJQS","status":"Successful"}
{"level":"info","ts":1586353217.6497335,"caller":"app/notification_push.go:321","msg":"Notification will be sent","logSource":"notifications","ackId":"acbfyszw3pf4xrgec4w8sgry4o","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"uzo34316ebfdd8nigghoekgkqh","status":"Prepared to send"}
{"level":"info","ts":1586353218.1821818,"caller":"app/notification_push.go:128","msg":"Notification sent","logSource":"notifications","ackId":"acbfyszw3pf4xrgec4w8sgry4o","type":"message","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"uzo34316ebfdd8nigghoekgkqh","channelId":"r6zngex9pff8dykjtq63b4paae","deviceId":"fp6yDJi01h8:APA91bGm7zSXgccwkYAJshGZaRUkpUGKbiITm5GtMJoJLZWkfidKtX71rlZF71DAAeeaBKzcasaIcGslug6KMaNe4mRMwmMPBMMKRAC5GIfn-CnDwtZdIkukyraih_DebJ3FRLkbHJQS","status":"Successful"}
{"level":"info","ts":1586353232.8505304,"caller":"app/notification_push.go:321","msg":"Notification will be sent","logSource":"notifications","ackId":"kunuk9bro7ba3kodwwdtiju6xo","type":"clear","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"","status":"Prepared to send"}
{"level":"info","ts":1586353233.3603194,"caller":"app/notification_push.go:128","msg":"Notification sent","logSource":"notifications","ackId":"kunuk9bro7ba3kodwwdtiju6xo","type":"clear","userId":"ccs81wigebfu7gpg7dnn79h86y","postId":"","channelId":"r6zngex9pff8dykjtq63b4paae","deviceId":"fp6yDJi01h8:APA91bGm7zSXgccwkYAJshGZaRUkpUGKbiITm5GtMJoJLZWkfidKtX71rlZF71DAAeeaBKzcasaIcGslug6KMaNe4mRMwmMPBMMKRAC5GIfn-CnDwtZdIkukyraih_DebJ3FRLkbHJQS","status":"Successful"}

Can I please confirm if the testings on the respective devices were done on the date and time mentioned above?