Ok I am officially incapable :( Locked out AGAIN!

Running self hosted MM from Docker behind an Apache2 web server without an SMTP server configured. Tried updating to the last image. Got locked out as admin. Please help

I have found a similar post of mine of some time ago and tried the same solution but am not succeeding. This time if I will succeed I PROMISE to document what needs to be done in more detail for my future self and possibly others.

Here is what I’m trying but am stuck :frowning:

started MM with the following command:
docker compose -f docker-compose.yml -f docker-compose.without-nginx.yml up -d2)

bob@newisa:~/mattermost$ docker compose ps mattermost
NAME                      IMAGE                                          COMMAND                  SERVICE      CREATED         STATUS                   PORTS
mattermost-mattermost-1   mattermost/mattermost-enterprise-edition:8.1   "/entrypoint.sh matt…"   mattermost   2 minutes ago   Up 2 minutes (healthy)   8067/tcp,>8065/tcp, :::8065->8065/tcp,>8443/tcp, :::8443->8443/tcp, 8074-8075/tcp,>8443/udp, :::8443->8443/udp
cd ~/mattermost/volumes/app/mattermost/config
vi config.json
changed "EnableLocalMode": true,

now restarted the docker with a down and up again:

docker compose down
docker compose -f docker-compose.yml -f docker-compose.without-nginx.yml up -d
[+] Running 2/3
 ⠇ Network mattermost_default         Created                                                                                                                                             0.9s 
 ✔ Container mattermost-postgres-1    Started                                                                                                                                             0.5s 
 ✔ Container mattermost-mattermost-1  Started

entered the container to use the mmctl command:
docker compose exec -it mattermost /bin/bash
and this is where I’m getting lost. I know my admin user is called bob and I think I do remember the email too.
mmctl --local user reset-password bob@MYDOMAIN.com
does not seem to do anything (do not have an SMTP enabled). I then tried this other variation:

mattermost@b49104413e51:~$ mmctl --local user change-password bob@MYDOMAIN.com
Current password: 
New password: 
Error: user bob@MYDOMAIN.com not found

so I guess I’m not remembering my email either :frowning: (or it got wiped out?)

mattermost@b49104413e51:/var/tmp$ ls -la
total 12
drwxrwxrwt 1 root       root       4096 Mar 27 17:18 .
drwxr-xr-x 1 root       root       4096 Mar  8  2023 ..
srw------- 1 mattermost mattermost    0 Mar 27 17:18 mattermost_local.socket

the socket file inside the container seems ok. Now even tried creating ad admin anew:

mattermost@b49104413e51:/var/tmp$ mmctl --local user create --email bob@MYDOMAIN.com --username bob --password MYSECRETPASS  --system-admin
Error: Unable to update user roles. Error: : We encountered an error finding the account., failed to get User with userId=zda8ggugairebj1b79wrps8fah: missing destination name lastlogin in *model.User

So I’m completely out of ideas. I really hope someone can help me sort out this rpyal mess I’ve stuck myself into. Thanks in advance