[Solved] Ashamed and locked out :(

Summary
I didn’t use my MM instance (Self hosted MM running from dockers (MM+PSQL)) for a few months and now am back and have the wrong password on both my app and my web password manager :frowning:

Underlying host does not have a configured sendmail so cannot peruse the “forgot your password” dialog.

I am the only sysadmin. My friend is only a team admin and sees me as a member of his team but does not have a console.

I tried entering the running docker and use the mmctl command as:

mattermost@89a86f4b4da8:~/config$ mmctl user change-password bob@isagog.com
Error: cannot read user credentials, maybe you need to use login first: stat /mattermost/.config/mmctl/config: no such file or directory

What else can I try? Thanks a lot.

Thanks to an old post from @agriesser I have got unstuck :slight_smile:

I have the config.json mounted as a bind mount on my host filesystem, so I edited the EnableLocalMode and restarted the server and postgres via the docker-compose up command.
I then entered MM container and from there mmctl --local and then mmctl user change-password.

Thanks a lot

1 Like

Yay! Thanks so much for following up to share the solution as well, Robert!