Self-Hosting Issues with Calls Plugin over HTTPS


I’ve recently self-hosted a Mattermost instance using Nginx and have installed the Calls plugin. However, I’ve encountered a couple of issues that I’m seeking help to resolve:

  1. Automatic Post Updates Over HTTPS: When accessing Mattermost over HTTPS, I’ve noticed that new posts are not automatically displayed in real-time. I have to manually refresh the page to see any new posts.
  2. Error with Calls Feature: I’m keen to utilize the Calls feature within Mattermost, but when attempting to start a call, I encounter an error message that says, “Something went wrong with calls.” This issue arises after waiting for an extended period, approximately 30 seconds, during which the call fails to connect.

I would greatly appreciate any guidance or assistance in addressing these problems. To provide context, here are some key details about my setup:

  • Mattermost Version: mattermost/mattermost-team-edition:8.1.0
  • Nginx Version: nginx:alpine

Many thanks!

I fixed these two problems by setting up "AllowCorsFrom": "*"
thanks to this post: Failed to upgrade websocket connection - #8 by robert9780

However, it’s not recommended in production; if somebody has a better solution, please let me know. Thanks!

Forget about Calls, they require money for it to work