[SOLVED] Help with hubot installation

Hello all,

I am trying to follow along with the hubot documentation (https://hubot.github.com/docs/).
I have installed node.js and npm on my ubuntu system without any issues but when I enter the command “npm install -g yo generator-hubot” it gives me a permissions error. I then add sudo in front of it and it runs. I then go to the next step to make a directory and try to run yo hubot. I then get the error “EACCESS: permission denied” even when I run it as sudo yo hubot.

Do any of you have any advice on how to proceed?
Thank you.

  • Victoria

Hi @vlee,

Thanks for your feedback,

@loafoe might be able to help with your Hubot issue

Solving this issue and linking to @vlee’s other issue: Hubot and mattermost adapter

I have seen this issue with NPM and yo on Xenial (16.04.3). This isn’t an issue with Mattermost really, but a problem of permissions as outlined here:


You can try to follow those steps and modify /root/.config /root/.config/configstore but in the end its better to start over with the installation process and follow it to the letter. The most likely cause of this is that you were root at some point in the install and that messed things up.

This comment in particular may shed some light on your issue: https://github.com/yeoman/yeoman.github.io/issues/282#issuecomment-69625203

good luck,

@ vlee
I also encountered this issue. what I do is create a new user account as a user then log out my root account then, log in again using the user account a created. after that i run the first command using sudo like “sudo npm install -g yo generator-hubot” then, run the second command without sudo “yo hubot --adapter matteruser”

Hope it will help you too

hey did you have mattermost running separately? did he integration happen successfully?