Hubot and mattermost adapter

Hello All,

I am trying to setup hubot with the mattermost adapter but am having some issues. I run the “yo hubot” command and it asks me for the adapter, I put mattermost but then ran into the warning "hubot-help@0.2.2 requires a peer of coffee-script@^1.12.6 but none was installed. I then ran npm install -g coffee-script and coffee-script 1.12.7 was installed.

I then go back to run hubot again and get the warning “UNMET PEER DEPENDENCY coffee-script@^1.12.6” and I see the adapter is still campfire not mattermost.

I am not sure how to proceed. Does anyone have any advice?

  • Victoria

Hi @vlee,

I’m going to resolve this issue and link it to the first one you opened as it’s a duplicate :slight_smile:

Please see: [SOLVED] Help with hubot installation

Hi @lindy65,

Thank you for your response. But can you actually mark the other one as a duplicate? I got that issue resolved but not this one.

  • Victoria

Hey @vlee,

Sorry about that, I’ve opened this one again and solved the other :slight_smile:

Thanks again :slight_smile:

1 Like


Just adding some more information. I received some advice to
"First run yo hubot and choose “shell” as adapter.
This wil setup the basic bot.
Then you need to install and configure a mattermost adapter, like this one:
npm install hubot-mattermost-adapter --save

After install you can then run that hubot with the mattermost adapter:
./bin/hubot --adapter mattermost-adapter"

After following the advice I get the message “EMERGENCY MATTERMOST_HOST is required”

Hi @vlee,

Did you see this comment on your other post? Not sure if it’s useful?

Hi @lindy65 Thank you for checking up on this post. Unfortunately, the comment is not relevant to this issue.

Thanks @vlee,

Just wanted to make sure :wink:

Does anyone have any advice?
I tried running ./bin/hubot --adapter mattermost-adapter and ended up with error login call failed. If I run ./bin/hubot I get the name of my hubot. Then when I ask for adapter it is still stuck as shell.

Hi @vlee,

You might want to post your question to ?

Hi @lindy65
currently, i use mattermost 5.16 and getting some error as @vlee.
i try to export some variable for creating environment but login fail case happen.
please support.
Thank you!

  • hubot version is 3.3.2

  • command
    ./bin/hubot --adapter mattermost-adapter

  • getting error log
    [Fri Nov 01 2019 08:46:28 GMT+0000 (Coordinated Universal Time)] INFO Logging in…
    [Fri Nov 01 2019 08:46:28 GMT+0000 (Coordinated Universal Time)] DEBUG GET /users/me
    [Fri Nov 01 2019 08:46:28 GMT+0000 (Coordinated Universal Time)] ERROR Login call failed
    [Fri Nov 01 2019 08:46:28 GMT+0000 (Coordinated Universal Time)] INFO Reconnecting in 1000ms

  • i use domain for setting up environment as below
    export MATTERMOST_HTTP_PORT=8065
    export MATTERMOST_WSS_PORT=8065
    export MATTERMOST_PASSWORD=08061989aA@
    export MATTERMOST_GROUP=chatting
    export MATTERMOST_LOG_LEVEL=debug
    export MATTERMOST_TLS_VERIFY=false
    export MATTERMOST_USE_TLS=false