[SOLVED] Hubot Docker Installation Succeeds but Integration Not Working

Hello I pulled the latest gitihub Docker file from:

The Docker Build and Run went find and I was put into the hubot cli when I ran the container.

[jonathanKlein@mattermost-demo-docker-instance hubot-matteruser]$ sudo docker run -it -p 8080:8080 --env MATTERMOST_HOST=chat.pwcdatasieve.com --env MATTERMOST_GROUP=innovation --env MATTERMOST_USER=jarvis@pwc --env MATTERMOST_PASSWORD=BotsAreCool --env MATTERMOST_SELFSIGNED_CERT=true --env MATTERMOST_HUBOT_USERNAME=jarvis --env --name hubot-matteruser hubot-matteruser
npm info it worked if it ends with ok
npm info using npm@2.15.11
npm info using node@v4.8.4
npm info preinstall jarvis@0.0.0
npm info package.json hubot-scripts@2.17.2 No license field.
npm info build /usr/src/hubot-matteruser
npm info linkStuff jarvis@0.0.0
npm info install jarvis@0.0.0
npm info postinstall jarvis@0.0.0
npm info prepublish jarvis@0.0.0
npm info ok
jarvis> [Thu Oct 19 2017 14:23:08 GMT+0000 (UTC)] INFO hubot-redis-brain: Using default redis on localhost:6379

jarvis> jarvis help
jarvis> jarvis adapter - Reply with the adapter

do I also need the mattermost-client installed?

I having trouble following the steps in the installation instructions.


@loafoe Would you be able to help with this issue?

@jasonblais @yocode see comment https://github.com/loafoe/mattermost-client/issues/48#issuecomment-338663547

I got the integration working. The issue was with my nginx proxy not setup to upgrade http requests to websocket.

Once I resolved this Hubot could login and listen without issue.