Hubot not connecting to Mattermost

Hello all,

I have a fresh install of Mattermost and trying to connect Hubot to it.
When I execute the command bin/hubot, the bot it starting fine but connecting it to Mattermost it fails:

bin/hubot -a mattermost

[Thu Feb 25 2016 12:17:23 GMT+0100 (CET)] EMERGENCY MATTERMOST_TOKEN is required

I now run this command:

MATTERMOST_TOKEN=TOKEN_HERE MATTERMOST_ENDPOINT=http://localhost:8080/hubot/incoming MATTERMOST_INCOME_URL=INCOME_URL_HERE ./bin/hubot --adapter mattermost

And get this:

[Thu Feb 25 2016 14:11:06 GMT+0100 (CET)] INFO hubot-redis-brain: Using default redis on localhost:6379

But bot is still not connecting

Hi @CrisKolkman,

  1. Just curious are you using hubot-mattermost or hubot-matteruser?

  2. Can you please help post full repro steps for your issue?

I deployed a hubot for our mattermost yesterday and everything works fine. We you hubot-mattermost.
Did you set environment variables? Or did you create a .hubotrc file with the correct export commands?

The exception in the first post looks like you did not set the correct environment variables.

As you can see in my second post, it seems that with the new command it’s accepting and starting, but still not connecting to mattermost.