[SOLVED] Not showing Full Name in team chat

Mattermost doesn’t show the full name of people in the chat

I installed the docker package, hooked it up to gitlab via oauth. Everything works just fine, except for the full name

I would have expected to see the full name if the settings of the “PrivacySettings” where set to “True” for “ShowFullName”.

No matter what i do, i still get to see the userid of the person, and not the full name. As an admin, when i am in the system console and check out a team i can see the full name above the email in the list. Which i would expect to see in the team channels too.

Also note, that when i am in the team channel, i only see the userid and email. I don’t see the full name at all. (Neither does it show a nickname, if i set one)

Any help would be appreciated.

Update: In Account settings -> Display -> Teammate Name display i can find the setting to update it, but i want to set this to another value for all new members. Otherwise its an extra thing they need to do.

Hi @riemers, thanks for the suggestion - we have a ticket here to add the ability for the System Administrator to set default display values.


even if I change “Teammate Name Display” in the user settings, the name is not shown in mentions.
This is pretty ugly in our case because in our company (Bosch) , user name look like this: abc2fe
From such a name you can never make out who this is.
Even if I hover over the mentioned username in the desktop app, the Full name is not shown

Hi @bnf2si,

I see you posted about this issue to Lindsay on our pre-release instance so I’ll close this issue off here as we can track via the conversation.

1 Like