[SOLVED] Push proxy error

I’m using the release 2.0 version of the push-proxy. When I tried to test it by running the curl command suggested in the instruction, I get the below error:

2016/05/08 14:52:17 INFO Loading /matter-push-proxy/config/config-push-proxy.json
2016/05/08 14:52:17 INFO Push proxy server is initializing…
2016/05/08 14:52:17 INFO Server is listening on :8066
2016/05/08 14:52:36 ERROR Failed to send apple push sid=XXXXX did=XXXX err=NO_ERRORS

I’m not sure what I did wrong. Any ideas?

The NO_ERRORS appears to the coming from the Apple servers which is strange. What ApplePushServer address do you have configured in config-push-proxy.json ? what OS are you running on?

actually…i updated the server config and it’s still not working…

here’s my current config file:

“ListenAddress”: “:8066”,
“ApplePushServer”: “api.development.push.apple.com:443”,
“ApplePushCertPublic”: “./config/publickey.pem”,
“ApplePushCertPrivate”: “./config/privatekey.pem”,
“AndroidApiKey”: “MM_ANDRIODKEY”,
“ThrottlePerSec”: 100,
“ThrottleMemoryStoreSize”: 10000,
“ThrottleVaryByHeader”: “X-Forwarded-For”

test command used:

curl http://XXX:8066/api/v1/send_push -X POST -H “Content-Type: application/json” -d ‘{ “message”:“test”, “badge”: 1, “platform”:“apple”, “server_id”:“XXX”, “device_id”:“XXX”}’


2016/05/18 00:17:14 ERROR Failed to send apple push sid=XXX did=XXX err=NO_ERRORS

Not too familiar with api.development.push.apple.com Can you try a cmd like openssl s_client -connect gateway.sandbox.push.apple.com:2195 -cert YourSSLCertAndPrivateKey.pem -debug -showcerts -CAfile server-ca-cert.pem to see if you can connect to the apple servers from your push proxy server

There were a lot of output, but i get below at the end… I suppose that means it’s working?

Start Time: 1463668733
Timeout   : 300 (sec)
Verify return code: 0 (ok)

Hi, I have the same error, and can also connect fine with openssl.
I am trying to connect to gateway.push.apple.com:2195 with an sandbox APN.

Did you resolve your issue?


Hi, I also tried with gateway.sandbox.push.apple.com:2195, and despite the fact the APN certificate is “Development”, I get an INVALID_TOKEN error, which would seem to mean there is a mismatch… 0_o

OK so it works me now, even though I have this in the mattermost log for each push:

2016/07/04 14:16:04 ERROR Failed to send apple push sid=cwkhfejkhfjkerhfjkerhfjkerhfjkre did=yxverjferhfjerhfjkrehf err=INVALID_TOKEN

APN dev cert and matching URL for apple push server (without password, otherwise it will fail because it cannot unlock it), right 0400 permission on the key file.

Hi man! let’s try to do it through this proxy servers http://advanced.name/ It has to help you :sunglasses: