[SOLVED] Silent push notifications on 3.4 (android app)


I’m trying (and failing) to get push notifications working properly on mattermost 3.4. The relevant config.json section goes as:

    "SendPushNotifications": true,
    "PushNotificationServer": "http://push-test.mattermost.com",
    "PushNotificationContents": "generic",
    "EnableEmailBatching": true,
    "EmailBatchingBufferSize": 256,
    "EmailBatchingInterval": 30

account settings : notifications : mobile push notifications is set for all activity, online away or offline. Sending a private message from @another_users account to @user , while tagging @user shows up on @user’s mm android app, but there is no notification sound and no visual notification outside the app (i.e. in the notification drawer) - tested & failed against 3 different android phones.

Is this a server or client problem?

Thanks, P.

Update: so, the android app actually does make a sound, but its Supersilent and andjusting volume doenst change this at all. Still no visual que.

Thanks for the report pavel,

We reproduced the bug with a faint sound and I’ve created an issue in Jira for us to track.

During testing, the notifications seem to appear in the notifications drawer for us. Can you help check the Mattermost notification settings on your phones have enabled these entries to the drawer?

Thank you once more Pavel for the report,

We’ve reproduced the issue after re-installing the Android app – I’ve created a ticket in Jira for us to track.

If anyone is interested in helping submit a fix, please let us know!

Hi @pavel, we’ve updated the Play Store app for v3.5 after being able to repro some of these push notifications issues. Please update and try again? Hopefully your issues should be solved.

Hey @eric, the problem has been resolved with 3.5, thanks lots!