[SOLVED] Unable to display Users and Groups


Users and Groups in Admin Console fails while stuck at “Loading…”

Steps to reproduce

Clean install using MySQL on a remote host. Able to create/edit users/groups via command line. Unable to access user management in the Admin Console.

No logs are generated at the Debug level when activating that screen.

Currently using local user authentication.

Version Details

Mattermost Version: 4.9.0
Database Schema Version: 4.9.0

Thanks for any tips and guidance.

Do you see any errors in the MySQL log?

Nope. No errors anywhere in MySQL or in the Mattermost logs. I turned on Debug and dev mode for query tracing and can’t find any issues.

Its actually pretty odd. The Mattermost logs don’t even show a query firing to the database when clicking the link to the Users and Teams screen.

I see the same issue when clicking the “Custom Integrations” pane in the Admin Console.

Problem has been solved. In the end the issue had nothing to do with Mattermost at all. There was a proxy server sitting between the end user and the server that was not forwarding Secure WebSocket traffic properly.

Great to hear @rdrushal :slight_smile:

I have the same problem (with pound as proxy server/load balancer). Can you tell me what you did to investigate and solve the problem?

I would like to know something about technical details. Why are only those two pages affected?

I was able to verify that it was the proxy server (of which I have no control or access over) by doing a port forward via a SSH tunnel to the server. I wasn’t able to find any particular technical details, just validated that the pipe via the proxy was the issue.