"Team URL not found" on iOS app setup

I can access my team’s URL fine through a web browser, but when I put the same URL in on the initial setup screen in the iOS app, an error message says “Team URL not found.” Any ideas>

try to enter the Team Url without trailing / (Slash)

e.g.: use www.mymattermost.org/team1
instead of www.mymattermost.org/team1/

Hi @captainmidnight

What version of the iOS app are you using? From v3.0 you don’t need to include the team name in the URL but for versions before this you do need to.

Thanks for the replies.

@githubkoma - I tried without the trailing / and I get the same error

@lindy65 - I am using version 2.1, its the same version that is in the App Store.


Can you try the URL without adding a team name at the end? e.g. http://servername.com

@lindy65 Still didn’t work

I have the same problem. Can access the team from a browser on iOS fine but the app tells me “Team URL not found”. I tried

all of the above resolve to the same error.
any ideas?

Can you confirm your Mattermost server version from the … -> About Mattermost dialog? The 3.0 server is not compatible with a 2.X client.

that would explain why my vps server setup doesn’t work as I have the 3.0 server version installed. but I also tried a local network installation with 2.2 via and it also is not available on the mobile client with the same error “team url not found”