Unable to restart service mattermost - During Omnibus installation

Omnibus install runs fine until ‘[TASK] Enable and restart Mattermost service’

Steps to reproduce
DigitalOcean droplet
Ubuntu 20.04.6 LTS
Followed steps on Install Mattermost Omnibus — Mattermost documentation

  1. Add the PPA repos
  2. Install Omnibus

Expected behavior
Start the Mattermost service

Observed behavior
Installing the omnibus package yields

journalctl -xe

yields this

Those pictures are hard to read! But the error is no such file as /opt/mattermost/bin/mattermost What does

find / -name mattermost 2>&1 | grep -v "Permission denied"


Sorry about the pictures, John, arent they hi-res enough? If not, I can send a link to them.

I ran the command you suggested and here’s what I got:

Your mattermost binary is in /usr/bin/ You’ll need to edit your systemd unit file to change /opt/mattermost/bin/mattermost to /usr/bin/mattermost

I’ll see if I can’t go through that install and find out where either it or the docs have a hiccup.

Thanks, John. I edited the systemd unit file as you suggested but no luck.


Attempting to start the service gives the following errors

journalctl -xe

What’s the result of

ls -lZ /usr/bin/mattermost

How about

ls -lZ /opt/mattermost/bin/mattermost

OK, there’s our problem! Something happened to the actual binary… /usr/bin/mattermost is a symbolic link that leads there, but it doesn’t exist. Worst case, download the tarball, extract the contents out, and copy it over from there.


That worked! Thank you, John!

It is all running well now, I am off to play around with it. :smile: