URL search returns no results (with PostgreSQL db)

Searching for an URL contained in a message returns no results. The server is self-hosted using a PostgreSQL database. I’ve found a few threads and issues on this problem, but they’re all marked as solved or closed without any solutions or workarounds provided. Any advice?

Hi lattich,

Welcome to the Mattermost community forums!

And thank you for reaching out and bringing this to our attention. I appreciate your patience and I understand how important it is for you to get this issue resolved.

Though you mentioned that the threads or issues you encountered were marked solved or closed, without much information, could you kindly provide some references to these? It could help us get a better understanding of your issue.

While we work on this, I recommend following these steps to see if they could help you resolve your problem:

  1. Verify your Mattermost server meets the minimum requirements, especially concerning the database.
  2. Try to reindex your database from System Console > Experimental > Elasticsearch > Indexing Options
  3. Ensure that the search feature is configured properly on your Mattermost server.

Please let us know the outcome of these steps.

Thank you again for being a part of our Mattermost Community. Your patience and contribution are highly valued.

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

Nice language model you have there, would be nicer if it could also search the web in addition to providing unhelpful advice.

forums post: [SOLVED] Search messages with URL keyword returns no results found

github issue: Search does not find words in URL's · Issue #5786 · mattermost/mattermost · GitHub

atlassian: [MM-1082] - Mattermost

Seems like nobody wants to actually fix this in the foreseeable future. Which is fine, but for some users this is an important feature, so it should be emphasized in the documentation that the (recommended) PostgreSQL DB has this known bug. Afaik no other DB type is currently recommended / supported, so there are no good solutions or workarounds.

1 Like

Hi @lattich - Search in SQL databases is notoriously hard to get right. There are tons of edge cases to consider and as such, SQL databases are not tuned for search.

What is recommended is to use a dedicated search database like Bleve or Elasticsearch: Elasticsearch — Mattermost documentation.

1 Like