Users can't edit or delete their posts in a channel when mentions are disabled


When the “Channel Mentions” permission is disabled for a channel, users are unable to edit or delete their posts.

Steps to reproduce

Mattermost 5.29
Go to System Console -> Channels
For a public channel, disable Channel Mentions

Expected behavior

Channel mentions are disabled but otherwise user permissions are unchanged

Observed behavior

Users no longer see any entries for Edit/Delete in the context menu for posts. Restoring Channel Mentions restores the Edit/Delete capability.

@ahmaddanial Is it possible that the ability to edit oneself’s posts is somehow tied to the ability to mention a user, and as such is being disabled as a pair?

Hi, @gubbins @XxLilBoPeepsxX

Sorry for the radio silence. I was on a very long leave.

I can confirm that the issue was not reproducible on local vanilla instance of 5.29.1 as you can see below:

  • The Channel Mentions is disabled for the Off-Topic* channel

  • The user is still able to edit / delete the post based on the screen shot below:

Can you please confirm on the following:

  • Is this happening to every team in the Mattermost instance?

  • Is it happening specifically on one channel or every other public channel as well?

  • Are you using Advanced Permissions?

  • Is this affecting every user type (normal / guest / System Administrators)?

1 Like


  • We only have one team
  • I only tested this on one public channel so far - will have to organise a test with another channel
  • I’m not sure how to say if we are “using Advanced Permissions” - could you clarify?
  • I’m a System Admin and I was not affected (can still do anything). I tried two other Normal users and they were both affected. We have no guest users.

I’ll try a different channel and report back…


1 Like

Something that stands out to me is

This makes me think that it may indeed be a permissions issue, or a network issue. I would be interested to see request/response logs of the HTTP requests made by both the System Admin as well as regular users, to look for the differences that will undoubtedly be there, if that is possible to log, @ahmaddanial?

Hello, @XxLilBoPeepsxX

Yeap, that sounds like a permission issue if it is only affecting specific user type (in this case, the normal users) with reference to the Advanced Permission documentation. Since you are the System Administrator, you should be able to check this through System Console > Permissions > Permission Scheme.

@gubbins Can you please provide the full screen shot of the permission scheme of all user types so we can compare them?

1 Like

1 Like

Hello, @gubbins

I have configured the same System Scheme on my 5.29 instance and verified that the edit & delete feature is still available when I disabled the Channel Mentions and saved the configuration for normal users.

Can I also please confirm if the issue persists on all platforms (desktop / web / mobile app)?

I will discuss this with the team as well to determine other factors that may influence the behavior that we are seeing here.

1 Like

OK, sorry for the delay - am trying to find a good time to organise some more tests here. I will aim to confirm behaviour for multiple public channels, multiple clients, and multiple users.

1 Like

This came up again today, so I tried it on our current 5.35.4 server.

Same problem reproduced on multiple channels and multiple users.

Any ideas on following this up? Am I really the only person to report it?

Actually, on further investigation, it seems that this was only affecting browsers, not desktop clients. When the user I was talking to closed and re-opened the browser tab they regained the edit/delete options.

So perhaps a minor javascript bug of some kind?

Hi, @gubbins

Can you please confirm which OS and the version you experience this on? Not to forget, the browser and its version too so I can test this on my end to fully verify if it is a JS bug or something else.

Also, can you please confirm the screen resolution that the user is utilizing on his/her end? Thanks.

User reports:

  • MacOS 10.14.6
  • Chrome 87.0.4280.88
  • Resolution 2880x1800 built-in, 3840x2160 external monitor

However, given that this was first reported 6 months ago and also reproduced by other users, I suspect that a range of these values would be affected.