Zapier fails to talk to mattermost (SSL errors)


Zapier connects to mattermost, but fails the test

Steps to reproduce

Mattermost version: 5.22.3

Visit Zapier apps, create mattermost app, then click “test”

Expected behavior

The test should succeed

Observed behavior

The test fails with the following error:

DataPostError: Problem creating Connected Account Test. (authentication failed: Javascript Exception: `Error: write EPROTO 140603982493568:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure:../deps/openssl/openssl/ssl/s23_clnt.c:802: `.)

The mattermost server url is

Hello, @mkozakov

Before I dig deeper into this, can you please confirm that you were referring to the Zapier Integration article to setup it up with your Mattermost Server?

If yes, can you please share the screen shot / configuration of the OAuth 2.0 Application from Zapier’s side when you registered it and the error that you see on the UI?

When you mentioned that you ran into the error when testing, what is the error shown on the UI? Since it is complaining about SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure, I ran a check on in SSL Labs test:

While the result shows that there is no support for TLS 1.3 and the error is related to sslv3, can you share the output of the following command (remove the values of TLSCertFile and TLSKeyFile since it contains sensitive value)?

cat /opt/mattermost/config/config.json | grep "TLS"

Hi Ahmad,

Thank you so much for looking into this!

  1. Yes I was referring to the article you linked
  2. Screenshots from Zapier
  3. I ran the command here is the output:
    “TLSCertFile”: “”,
    “TLSKeyFile”: “”,
    “TLSMinVer”: “1.2”,
    “TLSStrictTransport”: false,
    “TLSStrictTransportMaxAge”: 63072000,
    “TLSOverwriteCiphers”: ,
    “ConnectionSecurity”: “TLS”,
    “SkipTLSVerification”: false,

Hi, @mkozakov

You are welcome. I ran into some issue while configuring my local instance with Zapier:

I don’t see anything awry with the TLS configuration. May I know if you have reached out to the Zapier support team to verify the DataPostError that you are seeing? Is it stemming from Mattermost’s end or Zapier’s instead?

Hi, I actually didn’t have the issue you have - i can successfully go through the connection steps. It’s only after that that i start seeing errors. I can reach out to Zapier for help if that’s the right move.

Hi @mkozakov, we have the same problem, did you resolve it?

No, never got this resolved. Did you?

yes, if you use a RSA 2048 bits certificate in your sever then it works


I needed install a wildcard certificate for the 2048 bits

Hi, @mkozakov

Sorry that this got slipped under my radar. Anyway, did you get in touch with Zapier support on this and what was their feedback?