Black screen on Windows 10


This morning, I ran the latest Windows 10 (Enterprise, 64-bit) updates. After my computer rebooted, the whole Mattermost window is now black, except for the title bar (screenshot:

I’m running version 3.4.1 and I also tried 3.5.0-RC2 and the problem is the same.

I don’t know if this can help, but I’ve seen this problem once before: I was trying to enable triple monitor on my video card (NVIDIA NVS3100M) and the Optimus video drivers had all kinds of bugs (general Windows problems, and the Mattermost window was also black). I gave up and disabled Optimus in my BIOS and everything came back to normal, including Mattermost.

Thanks @kag for the report,

Can you try the following:

  1. Clear cache from the View > Clear Cache and Reload menu option?
  2. Go to the “Settings” page (from File > Settings), then hit “Save” on the page?
  3. Quit the app, then reopen?

Let me know if any of them helps resolve the issue. There might be something that got corrupted after the Windows update, of which the above three steps might help with.

If not, we’ll investigate the matter further.


As you can see in my screenshot, I can’t see the menu bar at all, so I can
clear the cache or access the settings.

If I right-click on the tray icon and select Settings, the screen remains

I tried clicking randomly in the black screen and I ended up opening a link
that was posted in the channel, so the window is still “alive”, it’s just

Hi @kag, in my understanding, the black screen appears not only for Mattermost, right?

Usually the desktop app try to use GPU acceleration as well as Chrome. So what I can say is that something happens in rendering when using Optimus. Would you try adding --disable-gpu option in Command Prompt?


It only happens for Mattermost. --disable-gpu did the trick. Is this
supposed to be a temporary or permanent solution?


Hello again,

I was about to modify my shortcut launcher to add --disable-gpu, but before
that, I tried launching using Windows 8 compatibility mode (out of
curiosity) and it works as expected. I don’t know if it’s using the GPU or
not at this point, but at least I can use it.


Thanks you for feedback. Unfortunately I’m also not sure why compatibility mode solved the problem. And I can only say --disable-gpu is temporary.

This is the first report in Windows, but there were similar problem on Linux. It’s a little hassle to add --disable-gpu every time if the problem is happening. We are planning to improve settings page in v3.6, so adding something for this might make sense.