Desktop App 4.4.0 Linux still freezing when message is received

This is very similar to

I hoped it would be gone with the upgrade from client version 4.3.x to 4.4.0, but alas - no. :frowning:


Whenever a message is received on any channel, the Desktop Application UI freezes and does not react to user interaction any more.

The application is not completely frozen, though, and still reacts to network events - the “user is typing” real time indicator still works, and new messages will come in and be shown in the channels.

It’s just not possible to interact with the application for quite some time. After some minutes have passed since the last incoming message was received, interaction is possible again - until the next message is received…

It happens most of the time this way, even though I also had a situation where I could use the application normally. This was not reproducable, though, so I have no idea what needs to be done to be able to use the application normally and without UI freezes.

This basically renders the application totally unusuable.

Steps to reproduce

Just start Mattermost Desktop Application 4.3.x or 4.4.0 Linux 64 Bit and try to use it.

Expected behavior

The application’s GUI should not freeze for several minutes when a message is received.

Observed behavior

See description above.

Further details about my system:

KDE neon User Edition 5.18, based on Ubuntu 18.04. HWE-Stack enabled for X server and kernel, so running on:

Linux Zweiblum 5.3.0-40-generic #32~18.04.1-Ubuntu SMP Mon Feb 3 14:05:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Graphics card is the integrated Intel graphics using modesetting driver.

Who experiences similar problems, or who knows any workaround?


I had similar issues with mattermost recently and what fixed for me on KDE-Neon was enabling notifications in the system tray.

Notifications were disabled and every time I received a message, mattermost would freeze and be unresponsive for minutes, changing it to any other option (show when relevant, always shown, always hidden) did the trick.

To do that on KDE-Neon, just right-click the task bar, and click on Edit Panel,
Then, mouse over the system tray and click Configure on the combo,
Go to the tab Entries and find the entry Notifications and change it’s visibility to any other option except disabled.
The app will instant unfreeze.

Hope it helps, cheers.

1 Like