Hipmost Support

A number of people have had issues with Hipmost, the command-line tool for migrating Hipchat data to Mattermost. Initially, the discussion of this topic was done on this thread, but I have hit my limit for replies as a new user. So I guess we are going to migrate discussion here.

Also, please feel free to use our issue tracker which may be better to use than posting here. I cannot post links to Github right now since I am a new user, but you can just head to github dot com slash orbitalimpact slash hipmost, go to the Issues tab and click New issue. Thank you.

Hey @ylluminarious, just a quick update. I found the problem as to why the hipmost private list command wasn’t working while assembling the sample data. My data set looks like:

β”œβ”€β”€ metadata.json
β”œβ”€β”€ rooms
β”‚ β”œβ”€β”€ 1
β”‚ β”‚ β”œβ”€β”€ files
β”‚ β”‚ └── history.json
β”‚ β”œβ”€β”€ 2
β”‚ β”‚ β”œβ”€β”€ files
β”‚ β”‚ └── history.json
β”‚ β”‚ …
β”œβ”€β”€ rooms.json
β”œβ”€β”€ users
β”‚ β”œβ”€β”€ 1
β”‚ β”‚ └── history.json
β”‚ β”œβ”€β”€ 2
β”‚ β”‚ └── history.json
β”‚ β”‚ …
β”‚ β”œβ”€β”€ files
└── users.json

The problem was solved by removing the files directory located within the users directory. I can only image the code is looking for a history.json file in each directory but fails to do so when hitting the files directory.

Thanks for providing that information! That sounds very plausible indeed. I’ll see what I can do to fix this.

Now that I have HipMost up and running I imported one of the rooms but I’m quite puzzled with the end result.

The room I’m trying to import is a private room with 3 users. The import does not produce any errors but first I have to use the MatterMost CLI to have the created users join the team and channel. I’m assuming this is an issue with the bulk import and not the jsonl file. Or a wrong expectation on my end. :thinking:
After that the room itself is empty… All message are within a direct message channel for that user. Or in other words all messages I ever posted in the channel are now in a direct channel to myself.

Are your problems fixed after the recent contributions on Github? If not, please let me know. I apologize for the radio silence over the past week; we’ve been rather busy with client work again so it’s hard to balance things. Thank you.

Hey @ylluminarious, I’m having the same problem hence the delay. Yes, the fix in the code worked. I can now export as expected.

1 Like

Thanks for letting me know!

Hi, I posted this over at GitHub, but it seems to be more active in here.

I’m receiving this error when I try convert a room:

/usr/local/lib/ruby/gems/2.5.0/gems/hipmost-1.0/lib/hipmost/hipchat/post.rb:8:in `initialize’: wrong number of arguments (given 2, expected 3) (ArgumentError)’’

I’ve updated to the latest hipmost using:
gem specific_install -l https://github.com/orbitalimpact/hipmost.git

Any suggestions?

Thank you

Sorry for the delay. I’ve replied on Github, so please check there.

Hi @ylluminarious - thanks for the tool. Looks to make life much easier (I’m hoping haha).

Unfortunately attempting to run it is giving the following error:

/usr/local/share/gems/gems/hipmost-1.0/lib/hipmost/mattermost.rb:2:in require_relative': /usr/local/share/gems/gems/hipmost-1.0/lib/hipmost/mattermost/channel.rb:4: syntax error, unexpected ',' (SyntaxError) def self.from_hipchat(room, name:, team: ) ^ /usr/local/share/gems/gems/hipmost-1.0/lib/hipmost/mattermost/channel.rb:14: syntax error, unexpected ',' def initialize(name:, team:, display_name:, type:, header:) ^ /usr/local/share/gems/gems/hipmost-1.0/lib/hipmost/mattermost/channel.rb:39: syntax error, unexpected keyword_end, expecting end-of-input from /usr/local/share/gems/gems/hipmost-1.0/lib/hipmost/mattermost.rb:2:in<top (required)>’
from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in require' from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:inrequire’
from /usr/local/share/gems/gems/hipmost-1.0/lib/hipmost.rb:4:in &lt;top (required)&gt;' from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:inrequire’
from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in require' from /usr/local/share/gems/gems/hipmost-1.0/exe/hipmost:7:in<top (required)>’
from /usr/local/bin/hipmost:23:in load' from /usr/local/bin/hipmost:23:in<main>’

Any ideas as to what may be causing this? It’s running on RH7.

Any help greatly appreciated.

Hi, thanks for the bug report. I’m having a hard time reading your message because the formatting is a bit wonky. Please head over to Github and file a new issue there; we can keep better track of it that way. Also, be sure to read up on Github’s markdown formatting so that it’s a little easier to read there :slight_smile:


Thanks for that. Has been done here - https://github.com/orbitalimpact/hipmost/issues/9