I am System Admin, other people don't get hint to tag me in regular channels

I am the System Admin on our 5.35.2 instance of Mattermost. In regular channels, even where I’m a member (e.g. Town Square, or channels I create myself), other people don’t get the hint to tag me when pressing the @ key and have to actually spell out my username, which then does work as a tag - they just don’t have the convenience of picking it from a list.

Regular users don’t get an option to tag the System Admin when pressing @ in regular channels, even when the System Admin is also a member

Steps to reproduce
On 5.35.2, set up a system admin and a regular user, and see if the regular user can @ mention the admin without having to spell out the admin username.

Expected behavior
Users should see the system admin as an option when using @ in channels, if the admin is also a channel member

Observed behavior
The system admin does not appear as an option when using @ in channels, and users who need to mention the admin are obliged to spell out the username themselves (some might argue this is a feature!)

Hi, @willmatheson

I tested this on my Mattermost 5.35.2 and verified that normal users can @mention me as the System Administrator as I am listed on the mention list as tested in the Town Square and Off-Topic (since they are the default channels):


When I am being @mentioned in the channel:

  • Can you share the screen shots of the behavior you are seeing on your end?
  • How did you configure your username on your account?
  • Is this also happening to other System Administrator accounts too?
1 Like

Thank you for the reply. Here is a slice of what I see when @ mentioning in town square:


When a colleague goes to @ mention, the list does come up (not shown here for privacy reasons and also because I am limited to one ‘media’ per post at the moment), but I don’t appear on it!

I am the only system administrator. I am unaware of any particular configuration of my username other than it is “wmatheson”.

Hi, @willmatheson

I tested this further by creating a test user and can confirm that there are no issues:


Even when I try to @mention myself:

Can you please attempt this on an Incognito browser after logging out and logging in again?

If you are on the desktop app, can you also clear the cache and reload the app?

From the screen shot, I can see that you are trying to mention yourself in the channel. Do you see the rest of the team when you typed @ and if you have a lot of members in the room, can you scroll down to view more?

Hi Ahmad, thanks again for your help with this.

I set up a new test user - oddly enough it said there was already an account on the system with my personal Gmail as the email, so I just stuck a period in it and it worked. No other versions of me show up on the Manage Members list, and the System Admin account, the account I use, uses my work e-mail.

For this test user, @johndoe, I used a separate browser, in private browsing mode and with the cache just cleared. And sure enough, @wmatheson does not appear on the list when typing @.

Funnily enough, I am no longer seeing myself when I go to @ while using my own account, contrary to my screenshot in my last message. But the list is able to scroll, and it does include all other team members, no matter who is typing @.

Hi, @willmatheson

Thank you for the confirmation. Can you please confirm if other users are also seeing this behavior on their end? The behavior that you are seeing is definitely strange. Any chance you can check on the database level to compare your account with the other users who are not affected?

SELECT * FROM Users WHERE Username = "<username>";

Did it used to work before or has it always been like this ever since you installed the Mattermost Server? If it was okay previously, do you remember any recent changes made to your account profile?

Yes, the other users are definitely seeing this behaviour - in fact, one of my colleagues alerted me to it, expressing frustration that I wasn’t in the list of people to mention when keying in @. (I’m the local ‘tech’ and many people come to me with their cares and woes.)

Id CreateAt UpdateAt DeleteAt Username Password AuthData AuthService Email EmailVerified Nickname FirstName LastName Position Roles AllowMarketing Props NotifyProps LastPasswordUpdate LastPictureUpdate FailedAttempts Locale Timezone MfaActive MfaSecret RemoteId
bu99dfzh4jb8fmhhsxr8rpcs7h 1623865659283 1623865659704 0 johndoe hash redacted! NULL my.personal.gmail@gmail.com 0 system_user 1 {} {channel:true,comments:never,desktop:mention,desktop_sound:true,email:true,first_name:false,mention_keys:,push:mention,push_status:away} 1623865659283 0 0 en {automaticTimezone:,manualTimezone:,useAutomaticTimezone:true} 0 NULL
bze9n17giprz9xgfmrc4gjofcr 1586298030919 1586298080136 0 wmatheson hash redacted! NULL myworkemail@workplace.tld 0 system_admin system_user 1 {} {channel:true,comments:never,desktop:mention,desktop_sound:true,email:true,first_name:false,mention_keys:wmatheson,@wmatheson,push:mention,push_status:away} 1586298030919 0 0 en {automaticTimezone:,manualTimezone:,useAutomaticTimezone:true} 0 NULL

Dunno if these “mention_keys” mean anything, but that’s the only difference I can see. But other users that can be mentioned seem to have similar keys to mine.

I don’t know if mentioning me by other users has ever worked. A lot of my colleagues don’t use all the features of the system. Judging from the table dump, only one (and not me) has actually put in their first and last name and position. Only two (and also not including me) have their e-mail verified. So it’s not impossible for this to have gone unnoticed until now. People have usually phoned or messaged me with the aforementioned cares and woes. I don’t recall making any recent changes to my account profile.

Hello, @willmatheson

Got it. I compared it with my working System Admin account here:

mysql> SELECT * FROM Users WHERE Username = "ahmad.danial"\G
*************************** 1. row ***************************
                Id: XXXXXXXXXXX
          CreateAt: 1623972210354
          UpdateAt: 1623972217998
          DeleteAt: 0
          Username: ahmad.danial
          Password: XXXXXXXXXXX
          AuthData: NULL
             Email: ahmad.danial@mattermost.com
     EmailVerified: 0
             Roles: system_admin system_user
    AllowMarketing: 1
             Props: {}
       NotifyProps: {"channel":"true","comments":"never","desktop":"mention","desktop_sound":"true","email":"true","first_name":"false","mention_keys":"","push":"mention","push_status":"away"}
LastPasswordUpdate: 1623972210354
 LastPictureUpdate: 0
    FailedAttempts: 0
            Locale: en
          Timezone: {"automaticTimezone":"Asia/Kuala_Lumpur","manualTimezone":"","useAutomaticTimezone":"true"}
         MfaActive: 0
1 row in set (0.00 sec)

Apart from the mention_keys in the NotifyProps column, I don’t see any differences there.

Can we then navigate to Account Settings > Notifications and ensure that the Word That Trigger Mentions are set to this?

Once done, log out and attempt to reproduce this again on the incognito web browser first before clearing the cache of the desktop app and test it there.

Ok, so to be clear, you would like me to deselect my “non case-sensitive username”? It is currently selected. Well, I’ll try it! That makes a slight change.

Ok, it looks like that did the trick! John Doe and my real colleagues see me when they key @. Strange that a setting to let people use “wmatheson” to mention me made me not appear when keying @. I don’t suppose Bleve or anything like that is to blame?

In any case, thanks very much for your help!


Hi, @willmatheson

You are most welcome. Any time!

If it is related to Bleve, it would affect the entire set of users unless they are not configuring their mentions similar to yours. Did you happen to check with the rest of the users if they have the same setting as yours?

1 Like

I checked with a coworker just now and they had what I had checked, checked, plus they had their name stored in their profile, so there was also an option for mentions of their first name, which was checked, which mine lacked entirely, probably because (according to the database dump anyway) I don’t have my name on it. Anyway, nobody’s had any problems mentioning him, nor anyone else. I’m content to leave this mystery unsolved since the problem is fixed for our part but do let me know if you wish for additional information.

Hi, @willmatheson

Interesting. Thanks for sharing that detail.

Now that it is working, any chance that the issue reappears again after you re-enable the Your non-case sensitive username “wmatheson” option again?

Were you referring to the SQL output you shared earlier were there are no Nickname, FirstName, LastName stored for your users?

I have re-enabled that setting and it looks as though my username is still appearing in the @ list as it should. So that’s good, although the root cause may remain a mystery.

Yes, I do mean the SQL output shared earlier, in the sense that only one of our users put their names in the name fields, and this was also the user whose settings I happened to check. I feel like this part of it all makes sense.

1 Like

Hello, @willmatheson .

Good to know that the fix persisted even after re-enabling those settings. You might be right on the absence of Nickname, FirstName, LastName attributes relating back to the issue though we do not have a solid proof on that. Should the issue happen again, we know what to check on next time.

Well, the thing is that whatever it was only affected me, even though most of the rest of my co-workers also didn’t put in values for those attributes. I only mentioned it because I couldn’t necessarily make my settings exactly the same as the coworker who did those values specified, because one of the settings’ very presence depends on those values being specified. I might be being excessively pedantic here.