Issue in creating user

For feature requests, please see:

For troubleshooting questions, please post in the following format:


Not able to sign up users - ‘We couldn’t save the account’ error

Steps to reproduce

After installation, create the first/admin user. Get the invite link and share with team to sign up.

Expected behavior

Mattermost version 3.8.0
OS : Suse 12
DB : MySQL/MariaDB 10.0.29

Installed all the above, updated the config.json with the DB details and started the mattermost server.
DB and mattermost are in separate VMs.

After creating the admin user, expected the other users to sign up using the invite link, but they couldn’t

Observed behavior

Was able to create the first/admin user and enabled sign-up of users without invite link. They got the sign-up form, but when they enter the details and submit, the mentioned error is thrown.
‘We couldn’t save the account.’

When checked the console & log file,

[2017/04/20 04:18:01 UTC] [EROR] Couldn’t save the user err=SqlUserStore.Save:, user_id=poauhy4j5iduipnu1qdgnm3pyy, Error 1210: Incorrect arguments to mysqld_stmt_execute

We’ve tried with the CLI as well,but getting the same issue.

Kindly help resolve.

Your help is much appreciated.

Thanks & Regards,

Hi @habib

Thanks for your issue report!

I have passed your query on to our devs to see whether there are any suggestions for you. In the meantime, I found this post on the forum which references MariaDB.

As soon as I have any news, I’ll let you know.

Thanks for your response.

I’ve already gone through that post and couldn’t find any pointers/suggestions for using MariaDB. I’ll wait for the response from the dev team. Meanwhile, i’m planning to downgrade/use MySQL 5.6, to see if the issue is because of the DB that i’m using.

Thanks & Regards
Habib Rahman
Manufacturing TEG - Java CoE
Tata Consultancy Services
Ph:- +91446616 9247
Cell:- 9094765645

Thanks for the feedback @habib!

Let us know how it goes once you’ve tried MySQL 5.6. Perhaps we could also have your help up-voting this suggestion on our feature forum?


Just wanted to say, I currently use mariadb 10.1 on my mattermost server without issues.