Keyboard shortcuts for copy paste on laptop don’t work


Keyboard shortcuts for copy and paste don’t work in Mattermost on my Lenovo laptop.

I have tried uninstalling and reinstalling the program multiple times.
It seems an old version of it persists (despite my attempting to delete it). I don’t know if this is the issue.

Can you check if the problem is also when you connect with the browser?

Thank you for your reply. I do not know how to connect with a browser. I have searched on the Mattermost home page and I don’t see a web browser option.

Just to add to this - I finally managed to delete all Mattermost files as well as uninstall it in order to do a clean install of it - and it won’t install. It is just hanging. (Windows 10).

You need to know the address of the mattermost server and type that into your browser

Hi @Zoph, as @JtheBAB mentioned, you can enter a link to the Mattermost into a browser like Chrome to access the site. For instance,

As for the Windows 10 installation issue, can you help share the exact steps you took and I’ll see what might be wrong?

Thanks @JtheBAB for helping here :+1:

Thank you for your replies!

Here are the steps I took:

I installed Mattermost on this new computer (Lenovo Ideapad) a few days ago. Upon realizing I cannot ctrl-c/v on it, I uninstalled and reinstalled it. When I did this, I realized it wasn’t really reinstalling a new program (no install wizard was appearing) it was clearly just opening a program that was already on the computer. No matter what I tried to delete, Mattermost files kept reappearing (that existed prior to my downloading the new file due to a file-restore). So I booted in safe mode and deleted every single Mattermost file I could find, and uninstalled it.

I re-downloaded it. When I tried to reinstall it, the install would just hang (green progress bar) at about 45% done. So I deleted that file and this time, I tried the MSI(beta) version. It installed normally - but the ctrl-c/v still doesn’t work. When I did a search for Mattermost, it looks like there is a Mattermost program file that keeps reappearing, and it dates back to November (whereas all other files are dated yesterday, the day when I did all of this).

By the way, the ctrl-c/v works for the Mattermost installed most of my other computers (my work Mac, a Lenovo 2-in1 tablet) but did not work on an old Dell running Ubuntu.

(Backstory: I restored the files for this new computer from an iDrive backup and I’m wondering if I mistakenly had it restore old program files. Since I’m also having problems on this new computer with it recognizing my password in SafeBoot I’m wondering if I should just do a factory reset and start over).

Sorry for the length. Hope the info is clear.

Hi Zoph,

Could you tell us more on how the uninstall was done? Please try doing it via either the Control Panel (Apps and Features section if you are on Windows 10) or via the uninstall option in the Mattermost folders directly : C:\Users<your username>\AppData\Local\Programs\mattermost-desktop


I think that I initially uninstalled using the Apps menu in Settings. That didn’t really do it, so I then did a safe boot and deleted any instance of Mattermost, and emptied out the Recycle bin in addition to uninstalling. There isn’t an uninstall option from within the Mattermost folder (at least not that I can tell) - but if it’s not an obvious program named “Uninstall” I may not be computer-literate enough to find it.


I wanted to revive this topic; I’m having the same problem with the copy and paste keyboard shortcuts.

Tried connecting to the server with the browser: everything works fine.

Here are more details regarding the problem. Ctrl+C, Ctrl+X and Ctrl+V don’t work; neither do the same commands when accessed through the window’s Edit menu. However, these commands work if I right click on the text and select the commands from the pop-up menu. Other keyboard shortcuts seem to work (e.g., Ctrl+A to select all).

I’m running the client on Linux (Mattermost client 4.3.2; KDE desktop, Kubuntu 19.10).

Thanks in advance for any help,


Would you be willing to test if v4.4.0-RC1 fixes the issue for you

1 Like

Hi. Version 4.4.0-RC1 fixes the issue!

Hi! This release fixed it for me as well! Thank you!