Mattermost v5.27 no configuration for elasticsearch and Bleve seems inactive

Hi, community :smiley: !

I found that mattermost is really good tool for cooperation with team members especially more than one teams which other tools do not support.

However, the basic search feature seems to operate by full word match.
So I am trying to connect elasticsearch engine to it or to activate Bleve found in experimental features of system console.

Environments

  1. ubuntu 16.
  2. mattermost v5.27 installed by docker-compose as introduced in official documentation.

The two issues I am facing are:

  1. There is no elasticsearch engine option in the system console of my mattermost web site.
  2. “Index now” button gives me error message:

Blockquote

Failed to run Bleve index job: engine is inactive. —

Would you guys help me out?
Thank you in advance!

Elasticsearch is an Enterprise feature https://docs.mattermost.com/deployment/elasticsearch.html#elasticsearch-e20. Are you on Team or Enterprise edition?

Is there any information in the server logs related to Bleve or any error log?

Got the same issue. Official doc (Bleve Search (Experimental) — Mattermost 5.37 documentation) doesn’t have a word that it’s a paid feature.
But the logs are a right place to see, even thought the unix timestamp is not the most understandable format for the human being… In my case it was a permission error - the engine could not start, because it could not write down to the directory specified.

mkdir /var/opt/mattermost/bleveindexes

chmod 777 /var/opt/mattermost/bleveindexes

mattermost system console’s text box;

  1. IndexDir: /var/opt/mattermost/bleveindexes
  2. set all checkbox to active

Then you can use Bleve.