Menu buttons & message edit not working on iphone8+

When I hold down on message or any of the menus I get the feeling of it being pressed, a small line appears at the bottom of the camera button and then goes away. Same thing happens for the + to add a new server and the menu bar at the top left.

Does not work on iphone 8+ (main phone) But seems to be ok on iPad pro, iPhone 6s & 14 pro max from other peoples testing.

I first spotted this on the previous TestFlight issue on both the servers I connect too, which I reported as thought as its was TestFlight it would not make it to live. The latest version of live brought this problem too.

iPhone 8+ IOS 16.7.4: Running Beta 2.13.0 (503) connecting to
Test Server: Mattermost Version: 9.4.1, Database Schema Version: 117, Database: postgres

iPhone 8+ IOS 16.7.4 Live app v2.12.0 connecting to
Live Server: Mattermost Version: 8.1.2 Database Schema Version: 113 Database: postgres

I have tried removing the app and its data from my phone and loading from scratch with no affect, changing screen font size/text makes no difference. I am also admin of both these systems.

I have also spotted that attachments do not show in message but I can work round that.

I ran the two before the app could support more than one system but kept the Beta to help with your testing.

Thank you

Hi Stuart (@haggis),

Thanks for reaching out and for providing such detailed information about the issue you’re experiencing. We appreciate your active involvement in helping us improve Mattermost, especially in maintaining the Beta to aid our testing. Our community greatly benefits from contributors like you.

I want to assure you that we have taken note of the problem you’re experiencing with the menu buttons and message editing on your iPhone 8+ while using the Mattermost app. It’ll be useful to determine if the problem consists across different versions of our app and on specific devices.

In the meantime, could you try to check if the issue persists when operating in different environments, perhaps on a wifi vs. mobile data connection? This will help us understand if the network plays any part in the problem. Additionally, confirming if the issue persists when you switch between dark and light mode may also be valuable information.

We’ll begin looking into the issue promptly and will keep you updated about our progress. Your patience and understanding are very much appreciated. Once again, thank you for your feedback and for helping us improve Mattermost.

Best regards,
~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

Hi there, we have fixed this bug and have submitted a v2.12.1 dot release to the app store and it will be available once Apple approves the release. In the meanwhile, the latest Beta version should work.

Hi Amy, that is great to hear. I have just used the Beta version and can confirm it is working for me.


Thank you very much all working on the live version.

1 Like