Mobile app sends notifications but can't connect to Server? [Winx64 / Android]

Version: 3.10.0
Database: MySQL
OS: Win10E 1703 x64
Configured for SSL

Platform: Android Samsung S7
Android 7.0
App Ver: 2017 (Beta) / also tried stable


The mobile app receives push notifications from the server, however, when opening the app, user is prompted for server URL.

Steps to reproduce

Install Android mobile app, reboot device.

Observed behavior

After initial config on mobile device, everything works fine. However, after several hours, and/or once the device is rebooted and the app is again launched, it will ask user for the server URL. User inputs Server URL, but will not connect with error: “cannot connect to the server. Please check your server URL and internet connection”

I’ve tried to uninstall the app, reboot the phone, but it will not connect after initial config, but I still get push notifications.
I can reach the server on the same device via mobile browser.


Hi @seanvree,

Thanks for your feedback,

What build number is your beta mobile app showing? Should be build 39 (Gear icon from top right of channels list > About Mattermost). We did have an issue with the app crashing in build 38 as you describe but this was fixed in build 39.

Also, could you post an example of the URL you’re trying to connect to.


I’m on build 34…downloaded from the google play store. Is there an updated .APK somewhere?

Url I’m trying to get to is

Hi @seanvree,

Build 39 is out for testing. If you join our Contributor’s Team you can either join the Native Mobile Apps channel and at mention Lindsay Brock or send her a direct message to add you as a Beta tester.

Does this help?

This still isn’t working for me. I’ve tested on the latest beta build and the master branch. If I uninstall the app, then I can connect for the first time, then one of two things will happen after a few hours:

Beta: Will just say "connecting"
Master: Plain white screen on the mobile device.

However, when I have either installed, I will still get push notifications.

1 Like

ok this is really really strange, there are a few things involved here:

  1. It seems that the user is being logged out, how long is the session on that server?
  2. looks like the user is logged out whenever opening the app, cause if the server no longer has the session it should not receive a push notification.
  3. “Connecting” al the time means that the websocket hasn’t been configured properly for APIv4, probably need an update in the nginx configuration, is your server behind an nginx reverse-proxy?

When you say “master” branch, are you talking about the mattermost-mobile repo?

  1. Where is the setting for the session length?

  2. Yeah, that’s what is weird. Always have been getting push notifications.

  3. Not running Nginx, running IIS. But, I’m connecting directly to the IP/hostname:PORT (ie: , so it’s not going thru the webserver, right?

Mobile app - when I say “master” I mean the non-beta app.

The setting for the session length can be found in System Console -> Security -> Sessions

for the push notifications I’m afraid that I really don’t understand the reason, maybe you should check that your user actually don’t have any other active session, you can do that in Account Settings -> Security -> View and Logout of Active Sessions and start fresh

My current settings are as follows:

Session Length: 30
Mobile: 30
SSO: 30
Cache 10 (Min)

Should I adjust any of these?